KB4014738 - CORRECTIF : Une erreur se produit lorsque vous abandonnez un abonnement en utilisant un compte non-sysadmin dans SQL Server

S’applique à
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Enterprise Core SQL Server 2012 Standard SQL Server 2012 Service Pack 3 SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

Symptômes

Lorsque vous supprimez un abonnement en utilisant un compte qui n’est pas membre du rôle de serveur fixe SQL Server sysadmin dans Microsoft SQL Server, bien que l’abonnement soit supprimé avec succès, un message d’erreur semblable au suivant peut s’afficher :

Remarque

  • L’abonné a été abandonné.
  • Msg 0, Niveau 11, État 0, Ligne LineNumber
  • Une grave erreur s’est produite sur la commande actuelle.  Les résultats, s’il y en a, doivent être ignorés

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

Mise à jour cumulative 6 pour SQL Server 2016 RTM

Mise à jour cumulative 3 pour SQL Server 2016 SP1

Mise à jour cumulative 5 pour SQL Server 2014 SP2

Mise à jour cumulative 12 pour SQL Server 2014 SP1

Mise à jour cumulative 8 pour SQL Server 2012 SP3

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2016

Dernière mise à jour cumulative pour SQL Server 2014

Dernière mise à jour cumulative pour SQL Server 2012 SP3

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.