Symptômes
Lorsque vous avez une base de données activée pour le suivi des modifications dans SQL Server, vous pouvez rencontrer une situation où vous pouvez voir l’erreur continue 22123 pour le même nom de table enregistré dans le journal des erreurs qui ressemble à ce qui suit :
Remarque
Erreur : 22123, Gravité : 16, État : 1.
Change Tracking nettoyage automatique est bloqué sur la table latérale de « tablename ». Si l’échec persiste, case activée si la table « tablename » est bloquée par un processus.
Résolution
Un correctif pour ce problème est inclus dans les mises à jour suivantes pour SQL Server :
Mise à jour cumulative 10 pour SQL Server 2017
Mise à jour cumulative 3 pour SQL Server Service Pack 2 2016
Mise à jour cumulative 1 pour SQL Server Service Pack 3 2014
Avec ce correctif, vous ne verrez plus de messages continus. La fréquence des messages d’erreur 22123, le cas échéant, ne sera pas plus d’une fois toutes les 30 minutes. Pour éliminer complètement ces messages, activez l’indicateur de trace 8293.
À propos des builds SQL Server
Chaque nouvelle build pour SQL Server contient tous les correctifs logiciels et correctifs de sécurité qui se trouvaient dans la build précédente. Nous vous recommandons d’installer la version la plus récente pour votre version de SQL Server :
La dernière version pour SQL Server 2017
Miseà jour cumulative L atest pour SQL Server 2016
Dernière mise à jour cumulative pour SQL Server 2014
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
Découvrez la terminologie standard utilisée par Microsoft pour décrire les mises à jour logicielles.