KB4575453 - CORRECTIF : SQL Server ne démarre pas lorsque les connexions d’administrateurs distants sont activées et que l’application IPv6 est désactivée sur l’hôte

S’applique à
SQL Server 2019 on Linux SQL Server 2017 Developer Linux SQL Server 2017 Enterprise Core on Linux SQL Server 2017 Enterprise on Linux SQL Server 2017 Standard on Linux

Symptômes

Lorsque les connexions d’administration à distance sont activées et que IPV6 est désactivé sur l’hôte dans Microsoft SQL Server 2019 ou 2017 sur Linux, vous remarquez que SQL Server tente d’écouter sur IPV6 mais ne démarre pas.

DateTime Erreur serveur : 26024, Gravité : 16, État : 1.

DateTime Serveur Le serveur n’a pas pu écouter sur « tout » <ipv6> 1434. Erreur : 0x2742. Pour continuer, prévenez votre administrateur système.

DateTime La prise en charge de la connexion administrateur dédié au serveur n’a pas démarré en raison d’une erreur 0x2742, status code : 0x1. Cette erreur indique généralement une erreur basée sur un socket, par exemple un port déjà utilisé.
      

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.