Symptômes
Supposons que vous utilisez Microsoft SQL Server 2012 Integration Service (SSIS 2012) ou SSIS 2014. Lorsque vous exécutez en interne un package SSIS contenant un autre ensemble de packages SSIS enfants, le processus ISServerExec.exe se bloque et l’exécution du package SSIS échoue par intermittence. En outre, le message d’erreur suivant est enregistré dans l’historique des tâches :
Remarque
Échec de l’exécution du package sur le serveur IS.
ID d’exécution : XXXXX, État d’exécution : 4.
Pour afficher les détails de l’exécution, cliquez avec le bouton droit sur le Catalogue Integration Services et ouvrez le rapport [Toutes les exécutions]
Dans le rapport du catalogue Integration Services, le status « Arrêt inattendu » s’affiche.
Remarque La version actuelle du correctif logiciel ne résout pas les problèmes dans le Gestionnaire de connexions Excel.
Résolution
Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.
Mise à jour cumulative 1 pour SQL Server 2014 SP1 /en-us/help/3067839
Mise à jour cumulative 8 pour SQL Server 2014 /en-us/help/3067836
Mise à jour cumulative 6 pour SQL Server 2012 SP2 /en-us/help/3052468
Mise à jour cumulative 7 pour SQL Server 2014 /en-us/help/3046038
Mise à jour cumulative 5 pour SQL Server 2012 SP2 /en-us/help/3037255
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2014 SP1
- Dernière mise à jour cumulative pour SQL Server 2012 SP2
- Dernière mise à jour cumulative pour SQL Server 2014
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».