Symptômes
Supposons que vous déployez un package Microsoft SQL Server 2014 Integration Services (SSIS) sur un instance Microsoft SQL Server 2014. Supposons également que le package contienne plusieurs tâches XML simultanées qui consomment la même feuille de style XSLT. Lors de l’exécution du package, le message d’erreur suivant s’affiche :
Remarque
[tâche XML] Erreur : une erreur s’est produite avec le message d’erreur suivant : « Le processus ne peut pas accéder au fichier '<File Path>', car il est utilisé par un autre processus. »
Remarque Ce problème se produit également dans SQL Server 2012.
Résolution
Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.
Mise à jour cumulative 4 pour SQL Server 2014 SP1
Mise à jour cumulative 10 pour SQL Server 2014
Mise à jour cumulative 7 pour SQL Server 2012 SP2
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Voir les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2014
- Dernière mise à jour cumulative pour SQL Server 2012 SP2
- Dernière mise à jour cumulative pour SQL Server 2014 SP1
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».