Symptômes
Supposons que vous utilisez WMI (Windows Management Instrumentation) pour surveiller les événements dans Microsoft SQL Server. Dans ce cas, une fuite de mémoire se produit dans le fichier sqlwepxxx.dll provoque le blocage du processus WmiPrvSe.exe et les messages d’erreur suivants sont enregistrés dans le journal des erreurs SQL Server :
Remarque
- Message d’erreur 1
- Erreur : 17003, Gravité : 16, État : 1.
Point de terminaison de conversation de notification d’événement fermé avec le handle « {CF29E9B8-33FA-E711-80DC-005056BB2DA5} », en raison de l’erreur suivante : « <?xml version="1.0 » ?><Erreur xmlns="http://schemas.microsoft.com/SQL/ServiceBroker/Error"><Code-8470<>/Code><Description>Le service distant a été supprimé.</Description></Error>'.
Remarque
- Message d’erreur 2
- Erreur : 17001, Gravité : 16, État : 1.
Échec de l’envoi d’une notification d’événement instance de type « ERRORLOG » sur le handle de conversation « {D229E9B8-33FA-E711-80DC-005056BB2DA5} ». Code d’erreur = '8429'.
Remarque
- Message d’erreur 3
- Erreur : 17005, Gravité : 16, État : 1.
La notification d’événement « SQLWEP_F7B4409C_33AD_4027_8008_07E894E7886F » dans la base de données « master » a été supprimée en raison d’erreurs du service Broker de temps d’envoi. Vérifiez que le handle de conversation, le contrat Service Broker et le service spécifiés dans la notification d’événement sont actifs.
En outre, un message d’erreur semblable à ce qui suit est enregistré dans le journal des événements de l’application :
Remarque
date et heure Avertissement server_name 5612 Microsoft-Windows-WMI N/A NT AUTHORITY\SYSTEM Windows Management Instrumentation s’est arrêté WMIPRVSE.EXE car un quota a atteint une valeur d’avertissement. Quota : PrivatePageCount Valeur : 537690112 Valeur maximale : 536870912 PID WMIPRVSE : 4244 Fournisseurs hébergés dans ce processus : C:\Windows\System32\wbem\WmiPerfClass.dll, C :\Program Files\Microsoft SQL Server\120\COM\sqlwep120.dll, C :\Program Files\Microsoft SQL Server\120\COM\sqlwep120.dll
Note Le fichier sqlwep120.dll est le fichier SQLWEP dans SQL Server 2014.
Résolution
Ce problème est résolu dans les mises à jour suivantes pour SQL Server :
Mise à jour cumulative 10 pour SQL Server 2017
Mise à jour cumulative 3 pour SQL Server 2016 SP2
Mise à jour cumulative 11 pour SQL Server 2016 SP1
Mise à jour cumulative 12 pour SQL Server Service Pack 2 2014
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et correctifs de sécurité qui se trouvaient dans la version précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Server 2017
Dernière mise à jour cumulative pour SQL Server 2016
les dernières mises à jour cumulatives pour SQL Server 2014
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
Découvrez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.