Symptômes
Supposons que vous disposez d’un rapport dans Microsoft SQL Server 2012 Reporting Services (SSRS 2012) ou dans SSRS 2014 en mode intégré SharePoint. Le rapport contient deux jeux de données qui sont liés à une liste SharePoint. Lorsque vous examinez le rapport, le message d’erreur suivant peut s’afficher :
Remarque
Une erreur s’est produite lors du traitement du rapport. (rsProcessingAborted)
Échec d’exécution de la requête pour le jeu de données «<DatasetName> ». (rsErrorExecutingCommand)
Un élément avec la même clé a déjà été ajouté.
Résolution
Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.
Mise à jour cumulative 1 pour SQL Server 2014 SP1 /en-us/help/3067839
Mise à jour cumulative 6 pour SQL Server 2014 /en-us/help/3031047
Mise à jour cumulative 4 pour SQL Server 2012 SP2 /en-us/help/3007556
Mise à jour cumulative 13 pour SQL Server 2012 SP1 /en-us/help/3002044
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2014 SP1
- Dernière mise à jour cumulative pour SQL Server 2014
- Dernière mise à jour cumulative pour SQL Server 2012 SP2
- Dernière mise à jour cumulative pour SQL Server 2012 SP1
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».