KB3028322 - CORRECTIF : Le rendu d’un rapport dans SSRS 2012 ou SSRS 2014 prend plus de temps que d’habitude

Symptômes

Supposons que vous rendiez un rapport dans Microsoft SQL Server 2012 Reporting Services (SSRS 2012) ou SSRS 2014 et que le rapport contient quelques petites erreurs, par exemple :

Remarque

bibliothèque ! ReportServer_0-8!4798!12/16/2014-16:33:01 :: i INFO : RenderForNewSession('/MyReport')
en cours de traitement ! ReportServer_0-8!4798!12/16/2014-16:33:03 :: e ERREUR : Renvoie Microsoft.ReportingServices.ReportProcessing.ReportProcessingException : , Microsoft.ReportingServices.ReportProcessing.ReportProcessingException : Il n’existe aucune donnée pour le champ à la position 8.
en cours de traitement ! ReportServer_0-8!4798!12/16/2014-16:33:33 :: e ERREUR : Renvoie Microsoft.ReportingServices.ReportProcessing.ReportProcessingException : , Microsoft.ReportingServices.ReportProcessing.ReportProcessingException : Il n’y a pas de données pour le champ à la position 9.

Dans ce cas, le rapport s’exécute correctement. Toutefois, la restitution du rapport peut prendre plus de temps que d’habitude. Chaque erreur peut entraîner un délai de 30 secondes.

Cause

Ce problème se produit parce que le chargement de l’objet inutile de gestion des erreurs est empêché par Reporting Services.

Résolution

Ce problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.

Mise à jour cumulative 1 pour SQL Server 2014 SP1 /en-us/help/3067839

Mise à jour cumulative 5 pour SQL Server 2012 SP2 /en-us/help/3037255

Mise à jour cumulative 6 pour SQL Server 2014 /en-us/help/3031047

Mise à jour cumulative 14 pour SQL Server 2012 SP1 /en-us/help/3023636

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

      

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».