Symptômes
Supposons que vous disposez d’un rapport qui se connecte à une liste SharePoint externe, puis que vous configurez un abonnement Microsoft SQL Server 2012 ou 2016 Reporting Services (SSRS) pour le rapport. Dans ce cas, l’abonnement ne s’exécute pas et le message d’erreur suivant s’affiche :
Remarque
Microsoft.ReportingServices.ReportProcessing.ReportProcessingException : échec d’exécution de la requête pour le jeu de données « DatasetName ». >--- Microsoft.BusinessData.Infrastructure.BdcException : L’exécution de shim a échoué de manière inattendue - La création du proxy a échoué. Contexte par défaut introuvable.
Cause
Ce problème se produit parce que l’objet SPServiceContext ou SPServiceContextScope n’a jamais été créé.
Résolution
Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :
Mise à jour cumulative CU 38 pour SQL Server 2016 SP1
Mise à jour cumulative 8 pour SQL Server 2012 SP3
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Server 2016
Dernière mise à jour cumulative pour SQL Server 2012 SP3
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.