KB3197631 - CORRECTIF : Les bases de données chiffrées par TDE sont dans un état suspect pendant la phase de récupération lorsque vous redémarrez SQL Server

S’applique à
SQL Server 2012 Service Pack 3 SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Enterprise Core SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Express - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptômes

Supposons que vous disposez d’une base de données chiffrée TDE (Transparent Data Encryption) sur une instance de Microsoft SQL Server. Quand vous redémarrez l’instance de SQL Server, une erreur de délai d’attente du verrouillage semblable à la suivante peut s’afficher :

Remarque

Démarrage de la base de données <DatabaseName>.
Erreur : 1222, Gravité : 16, État : 55.
La période d’attente de la demande de verrouillage a été dépassée.
Erreur : 9016, Gravité : 21, État : 7.
Une erreur s’est produite lors du traitement du journal pour la base de données <DatabaseName>. Le bloc de journal n’a pas pu être déchiffré.

Ensuite, la base de données sera dans un état suspect. Vous pouvez remettre la base de données en ligne à l’aide du mode d’urgence. Vous ne rencontrerez pas de corruption.

Résolution

Ce problème a été résolu dans les mises à jour cumulatives suivantes pour SQL Server :

      Mise à jour cumulative 2 pour SQL Server 2016 SP1

Mise à jour cumulative 4 pour SQL Server 2016

Mise à jour cumulative 3 pour SQL Server 2014 SP2 

      Mise à jour cumulative 10 pour SQL Server 2014 SP1

Mise à jour cumulative 6 pour SQL Server 2012 Service Pack 3

À propos des mises à jour cumulatives pour SQL Server

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2016

Dernière mise à jour cumulative pour SQL Server 2014 SP1/SP2

Dernière mise à jour cumulative pour SQL Server 2012

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.