Symptômes
Lorsque vous exécutez une requête qui utilise des données issues de vues de gestion dynamique (DMV) sys.dm_db_uncontained_entities, un message d’erreur semblable au suivant s’affiche :
Remarque
Msg 0, Niveau 11, État 0, Ligne 0
Une grave erreur s’est produite sur la commande actuelle. Les résultats, s’il y en a, doivent être ignorés.
Msg 0, Niveau 20, État 0, Ligne 0
Une grave erreur s’est produite sur la commande actuelle. Les résultats, s’il y en a, doivent être ignorés.
Résolution
Informations sur les Service Packs
Ce problème a été résolu pour la première fois dans le Service Pack pour SQL Server suivant.
Service Pack 2 pour SQL Server 2014
SQL Server 2016 Service Pack 1
À propos des Service Packs pour SQL Server
Les Service Packs sont cumulatifs. Chaque nouvelle version contient tous les correctifs fournis dans les Service Packs précédents et tous les nouveaux correctifs. Il est recommandé d’appliquer le dernier Service Pack et la dernière mise à jour cumulative pour ce Service Pack. Il n’est donc pas nécessaire d’installer la version antérieure d’un Service Pack avant d’installer la dernière version disponible. Consultez le tableau 1 de l’article suivant pour trouver plus d’informations sur le dernier Service Pack et la dernière mise à jour cumulative.
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».