KB4465867 - CORRECTIF : erreur « mémoire insuffisante » lors de l’exécution d’une requête sur une table qui a un index de recherche en texte intégral volumineux dans SQL Server 2014, 2016 et 2017

S’applique à
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer on Windows SQL Server 2017 Enterprise on Windows SQL Server 2017 Enterprise Core on Windows SQL Server 2017 Standard on Windows

Symptômes

Supposons que vous disposez d’un index de recherche en texte intégral sur une table qui contient des documents très volumineux dans Microsoft SQL Server 2014, 2016 ou 2017. Lorsque vous exécutez une requête sur la table, vous recevez des messages d’erreur de mémoire insuffisante qui ressemblent aux suivants :

Remarque

Erreur : 30086, Gravité : 17, État : 8.
Le système a manqué de mémoire lors de la création d’un index de recherche en texte intégral. Le lot de l’opération d’indexation de texte intégral est automatiquement retenté à l’aide d’une taille de lot plus petite.

Résolution

Ce problème est résolu dans les mises à jour suivantes pour SQL Server :

Mise à jour cumulative 13 pour SQL Server 2017

Cumulatvie Update 4 pour SQL Server 2016 SP2

Mise à jour cumulative 12 pour SQL Server 2016 SP1

Mise à jour cumulative 1 pour SQL Server 2014 SP3

Mise à jour cumulative 14 pour SQL Server 2014 Service Pack 2

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et correctifs de sécurité qui se trouvaient dans la version précédente. Nous vous recommandons d’installer la version la plus récente pour votre version de SQL Server :

Dernière mise à jour cumulative pour SQL Server 2017

Dernière mise à jour cumulative pour SQL Server 2016

versions de build SQL Server 2014

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

Découvrez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.