Symptômes
Supposons que vous disposez d’une base de données activée pour le suivi des modifications dans SQL Server 2014, 2016 et 2017. Vous pouvez rencontrer une situation où la tâche de nettoyage automatique de suivi des modifications peut signaler le message d’erreur 22122/22123 avec le nom de la table sous forme de caractères broutés, ou elle peut rencontrer une violation d’accès lorsque vous imprimez le message d’erreur. En outre, vous pouvez remarquer que le vidage de la pile se produit. Le journal des erreurs est le suivant :
< Datetime> spid# Erreur : 22123, Gravité : 16, État : 1.
< Datetime> spid# Change Tracking autocleanup est bloqué sur la table latérale de « ». Si l’échec persiste, case activée si la table « » est bloquée par un processus .
< Datetime> spid# ***Stack Dump envoyé à <FileLocation>
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Résolution
Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :
- Mise à jour cumulative 14 pour SQL Server 2017
- Mise à jour cumulative 6 pour SQL Server 2016 SP2
- Mise à jour cumulative 4 pour SQL Server 2014 SP3
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2017
- Dernière mise à jour cumulative pour SQL Server 2016
- Dernière mise à jour cumulative pour SQL Server 2014
Solution de contournement
Pour contourner le problème, vous pouvez activer l’indicateur de trace 8293.
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.