KB4497230 - CORRECTIF : Impossible de joindre le réplica secondaire si la base de données a un groupe de fichiers obsolète dans les SQL Server 2014, 2016 et 2017

S’applique à
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Service Pack 2 SQL Server 2016 Service Pack 1 SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer Windows SQL Server 2017 Enterprise Windows SQL Server 2017 Enterprise Core Windows SQL Server 2017 Standard Windows

Symptômes

Prenons le scénario suivant :

  • Vous avez une base de données avec un groupe de fichiers obsolète que vous essayez d’ajouter à un groupe de disponibilité (AG) Always On dans Microsoft SQL Server 2014, 2016 et 2017.
  • Vous pouvez ajouter la base de données à la réplica principale et restaurer les sauvegardes complètes et de journaux avec NORECOVERY sur le réplica secondaire sans problème.

Dans ce scénario, lorsque vous essayez de joindre la base de données au groupe de disponibilité sur le réplica secondaire avec ALTER DATABASE <DatabaseName> SET HADR AVAILABILITY GROUP = <AGName> ou d’utiliser l’amorçage automatique pour configurer les réplica secondaires, vous remarquez que les erreurs 17207 et 5120 sont signalées pour le fichier de données dans le groupe de fichiers obsolète :

## spid## Démarrage de la base de données 'DatabaseName'.

## spid## Erreur : 17207, Gravité : 16, État : 1.

## spid## FileMgr ::StartSecondaryDataFiles : l’erreur du système d’exploitation 2 (Le système ne trouve pas le fichier spécifié.) s’est produite lors de la création ou de l’ouverture du fichier « FilePath ». Diagnostiquer et corriger l’erreur du système d’exploitation, puis réessayer l’opération.

## spid## Erreur : 5120, Gravité : 16, État : 5.

## spid## Impossible d’ouvrir le fichier physique « FilePath ». Erreur du système d’exploitation 2 : « 2 (Le système ne peut pas trouver le fichier spécifié.) ».

Vous verrez également la base de données passer en mode Non synchronisation/Récupération en attente sur le réplica secondaire après l’exécution de la commande ALTER DATABASE.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.