« Action n’est pas disponible. Pour utiliser cette action, vous devez d’abord sélectionner l’ancienne solution et puis réessayez » message s’affiche dans Dynamics 365

Symptôme

Lorsque vous sélectionnez une solution dans Dynamics 365, puis cliquez sur le bouton Appliquer la mise à niveau de la Solution, vous rencontrez l’erreur suivante :

« Action n’est pas disponible.

Pour utiliser cette action, vous devez d’abord sélectionner l’ancienne solution et puis essayez à nouveau. »

Si vous cliquez sur Télécharger le fichier journal, le fichier journal inclut une référence au code d’erreur-2147187396.

Cause

Ce message s’affiche si la solution que vous avez sélectionné n’est pas la solution parente et la mise à jour de la solution.

Le bouton Appliquer la mise à niveau de la Solution est destiné à être utilisée lorsque vous avez importé une mise à jour pour une autre solution qui est déjà installée. Lors de l’importation de la solution mise à jour, il existe une option « Étape de mise à niveau » qui s’affiche. Si cette case à cocher est activée, l’action de mise à niveau n’est pas effectuée au cours de l’importation de la solution. Un bouton d’appliquer la mise à niveau de la Solution apparaît à la fin du processus d’importation. Si vous n’avez pas cliqué sur ce bouton, vous pouvez rechercher la solution parent dans la liste et puis cliquez sur Appliquer la mise à niveau de la Solution. 

Exemple : Vous avez précédemment importé une solution appelée quinon qui était la version 1.0.0.0. Plus tard, vous importez une version plus récente de quinon qui est la version 1.0.1.0. Lors de l’importation de la solution, l’option « Étapes de mise à niveau » a été sélectionnée. Si vous n’avez pas cliqué sur le bouton Appliquer la mise à niveau de la Solution qui s’est affichée à la fin du processus d’importation, vous verrez quinon et SolutionA_Upgrade dans l’affichage de toutes les Solutions. Si vous sélectionné SolutionA_Upgrade et ensuite cliqué sur Appliquer la mise à niveau de la Solution, vous voyez cette erreur. Au lieu de cela, vous devez sélectionner la solution parent (quinon), puis que vous cliquez sur Appliquer la mise à niveau de la Solution.

Résolution

Sélectionnez la solution de parent, puis cliquez sur Appliquer la mise à niveau de la Solution.

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×