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Symptômes

Lorsque vous vous connectez à partir d’un ordinateur Windows 7 à un espace de noms DFS (partage de fichiers réseau) sur Windows Server 2008 R2, le changement de nom ou de l’enregistrement de fichiers que qui se trouvent dans le deuxième niveau de profondeur du sous-répertoire (par exemple, z:\d1\d2) peut échouer avec :

« Le fichier ou le dossier n’existe pas. »

Si un fichier est enregistré dans le répertoire z:\d1\d2, le fichier réellement apparaîtra également dans le répertoire racine de z:\ à la place.

Cause

Ce problème peut se produire si l’ordinateur client Windows 7 se connecte au partage de fichiers réseau DFS à l’aide de la syntaxe \\ipaddress\SHARENAME, mais le client ne parvient pas à se connecter au serveur à l’aide de son nom (par exemple, \\servername\SHARENAME). Lorsqu’un client Windows 7 se connecte à la \\ipaddress\SHARENAME, le serveur indique que le nom du partage est en fait un espace de noms DFS. Le client utilise en interne le nom du serveur DFS pour effectuer le suivi de l’emplacement de la connexion réseau, mais en cas d’échec de la résolution de noms pour le nom du serveur, le chemin d’accès du dossier n’est pas suivi correctement.

Résolution

Pour résoudre ce problème, appliquez le correctif sur l’ordinateur client, ou suivez les étapes décrites dans la solution de contournement.

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et support technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :

http://support.microsoft.com/contactus/?ws=supportRemarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, vous devez exécuter Windows 7 Service Pack 1 (SP1).

Pour plus d'informations sur la façon d'obtenir un service pack Windows 7 ou Windows Server 2008 R2, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

976932 les informations sur le Service Pack 1 pour Windows 7 et Windows Server 2008 R2

Nécessite un redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace pas un correctif précédemment publié.

Informations sur les fichiers

La version anglaise (États-Unis) de ce correctif logiciel installe des fichiers dont les attributs sont répertoriés dans les tableaux ci-dessous. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Les dates et heures de ces fichiers sur votre ordinateur local sont affichées dans votre heure locale en tenant compte de l'heure d'été (DST). En outre, les dates et heures peuvent changer lorsque vous effectuez certaines opérations sur les fichiers.

Remarques sur les fichiers Windows 7


Important Les correctifs logiciels Windows 7 et Windows Server 2008 R2 sont inclus dans les mêmes packages. Toutefois, les correctifs dans la page de demande de correctif logiciel sont répertoriés sous les deux systèmes d’exploitation. Pour demander le package de correctif qui s’applique à un ou deux systèmes d’exploitation, sélectionnez le correctif logiciel qui est répertorié sous « Windows 7/Windows Server 2008 R2 » sur la page. Reportez-vous toujours à la section « S’applique à » dans les articles pour déterminer le système d’exploitation actif auquel s’applique chaque correctif.

  • Les fichiers qui s'appliquent à un produit spécifique, SR_Level (RTM, SPn), et à une branche de service (LDR, GDR), peuvent être identifiés en examinant les numéros de version de fichier comme indiqués dans le tableau suivant :

    Version francaise

    Produit

    SR_Level

    Dossier

    6.1.760
    1.
    22 xxx

    Windows 7

    SP1

    LDR

  • Les fichiers MANIFEST (.manifest) et MUM (.mum) qui sont installés pour chaque environnement sont répertoriés séparément dans la section « informations de fichiers supplémentaires pour Windows 7 ». Les fichiers MUM et MANIFEST et les fichiers de catalogue de sécurité (.cat) associés sont extrêmement importants pour conserver l'état des composants mis à jour. Les fichiers de catalogue de sécurité, pour lesquels les attributs ne sont pas répertoriés, sont signés avec une signature numérique Microsoft.

Pour toutes les versions x86 de Windows 7 prises en charge

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Mrxsmb20.sys

6.1.7601.22013

96,768

07-Jun-2012

02:22

x86

Pour toutes les versions 64 bits prises en charge de Windows 7

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Mrxsmb20.sys

6.1.7601.22013

128,000

07-Jun-2012

02:45

x64

Plus d'informations

Pour plus d'informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft

Informations sur les fichiers supplémentaires

Informations sur les fichiers supplémentaires pour Windows 7

Fichiers supplémentaires pour toutes les versions x86 prises en charge de Windows 7

Nom de fichier

Update.mum

Version de fichier

Ne s'applique pas

Taille du fichier

2,136

Date (UTC)

07-Jun-2012

Heure (UTC)

08:05

Plateforme

Ne s'applique pas

Nom de fichier

X86_1e185a624ec55ec274ac14b9cc355b04_31bf3856ad364e35_6.1.7601.22013_none_5143c74e912cd003.manifest

Version de fichier

Ne s'applique pas

Taille du fichier

701

Date (UTC)

07-Jun-2012

Heure (UTC)

08:05

Plateforme

Ne s'applique pas

Nom de fichier

X86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.22013_none_8d6ad9dc0126ab2b.manifest

Version de fichier

Ne s'applique pas

Taille du fichier

4,035

Date (UTC)

07-Jun-2012

Heure (UTC)

06:01

Plateforme

Ne s'applique pas

Fichiers supplémentaires pour toutes les versions x64 prises en charge de Windows 7

Nom de fichier

Amd64_9e65ee6acfddfd7eb14dd4694dd6a04b_31bf3856ad364e35_6.1.7601.22013_none_0e3b97db9b019ff6.manifest

Version de fichier

Ne s'applique pas

Taille du fichier

705

Date (UTC)

07-Jun-2012

Heure (UTC)

08:05

Plateforme

Ne s'applique pas

Nom de fichier

Amd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.22013_none_e989755fb9841c61.manifest

Version de fichier

Ne s'applique pas

Taille du fichier

4,039

Date (UTC)

07-Jun-2012

Heure (UTC)

06:56

Plateforme

Ne s'applique pas

Nom de fichier

Update.mum

Version de fichier

Ne s'applique pas

Taille du fichier

2,350

Date (UTC)

07-Jun-2012

Heure (UTC)

08:05

Plateforme

Ne s'applique pas

Plus d'informations

Alors que le problème peut être reproduit lors de la connexion depuis Windows 7 vers Windows Server 2008 R2, il requiert un espace de noms DFS d’être configuré pour NOM_PARTAGE afin que le bit « Capable de DFS » est défini sur la réponse SMB2 Tree Connect.

Après la connexion à un partage DFS sur le serveur à l’aide de la syntaxe \\ipaddress\SHARENAME, aucune erreur ne s’affiche en cas d’échec de la résolution de nom sur le serveur, afin que le problème d’accès au fichier/dossier n’apparaît pas.

Solution de contournement

Pour résoudre ce problème, assurez-vous que le client peut se connecter au serveur à l’aide de son nom, son adresse IP au lieu de Windows 7. Ou bien, si vous reconfigurez le client pour que la résolution de noms pour le nom du serveur est réussie. Par exemple, assurez-vous que le nom DNS du client est correct, ou ajouter une entrée du fichier hosts pour indiquer l’adresse IP / nom de mappage.

Par exemple, à partir d’une invite de commandes d’administration, démarrez le bloc-notes et ouvrez c:\windows\system32\drivers\etc\hosts et ajoutez une entrée. Par exemple, si le nom de votre serveur est « Nom_serveur » et son adresse IP est 10.0.0.1, ajoutez :

10.0.0.1 nom_serveur

REMARQUE : Le client peut être en mesure de contourner le problème en toujours se connecter au serveur à l’aide de la syntaxe \\servername\SHARENAME. Cela entraînera le client à rencontrer une erreur de connexion lors de la connexion au serveur en cas d’échec de résolution de noms.

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