Un problème s’est produit lors de l’affichage du message d’erreur de connexion lorsque vous accédez à Microsoft Dynamics 365 App pour Outlook

Cet article fournit une solution à une erreur qui se produit lorsque vous accédez à Microsoft Dynamics 365 App pour Outlook.

S’applique à : Microsoft Dynamics 365 Customer Engagement Online
Numéro de la base de connaissances d’origine : 3064194

Symptômes

Lorsque vous sélectionnez l’application Dynamics 365 dans Outlook (partout où l’application est prise en charge), le message suivant s’affiche :

Un problème s’est produit lors de la connexion. Réessayez. Si le problème persiste, contactez votre administrateur système.

Cause

Cause 1

Microsoft Dynamics 365 App pour Outlook n’a pas pu se connecter au service d’autorisation pour vous assurer que vous êtes autorisé à utiliser cette application.

Cause 2

Ce problème peut se produire si votre URL de Dynamics 365 (en ligne) a été modifiée après l’installation de l’application Dynamics 365 pour Outlook. Par exemple : si votre URL de Dynamics 365 était <https://contosocorp.crm.dynamics.com> lorsque vous avez déployé l’application, mais que vous avez modifié l’URL par <https://contoso.crm.dynamics.com> ultérieurement.

Résolution

Résolution 1

Fermez l’application et ouvrez-la à nouveau. Si le problème persiste, essayez de fermer votre navigateur Internet et de le rouvrir. Si le problème persiste, essayez la solution de l’erreur « Un problème s’est produit pendant la connexion » à l’aide de Dynamics 365 App pour Outlook.

Résolution 2

Si vous avez modifié votre URL de Dynamics 365 (en ligne) après l’installation de Microsoft Dynamics 365 App pour Outlook, vous devez redéployer l’application :

  1. Un utilisateur disposant du rôle Administrateur système peut redéployer l’application vers les utilisateurs en ouvrant l’application web Dynamics 365, puis en accédant à la zone Dynamics 365 App pour Outlook dans Paramètres.
  2. Sélectionnez les utilisateurs auxquels l’application doit être redéployée et utilisez l’un des boutons Ajouter une application pour redéployer l’application.
  3. Une fois que l’état est passé à Ajouté à Outlook, vous pouvez vérifier si le problème a été résolu. Si l’application était déjà ouverte, fermez-la et rouvrez-la.

Plus d’informations

Vous pouvez vérifier si ce problème est le résultat de la Cause 2 en cliquant avec le bouton droit sur le lien M’aider à résoudre ce problème dans le message d’erreur et en copiant l’URL. Si vous affichez les paramètres d’URL, elles contiennent l’ancienne URL Dynamics 365. Dans l’exemple fourni précédemment, il affiche l’ancienne URL (contosocorp.crm.dynamics.com) au lieu de votre URL Dynamics 365 actuelle (contoso.crm.dynamics.com).