« Valeur d’ordre d’affichage non valide. L’ordre d’affichage doit être supérieur ou égal à 10 000 ». L’erreur se produit lors de l’importation d’une solution dans Microsoft Dynamics 365

Cet article fournit une solution à une erreur qui se produit lors de l’importation d’une solution dans Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de la base de connaissances d’origine : 4465876

Symptômes

Lorsque vous tentez d’importer une solution dans Dynamics 365, vous recevez l’erreur suivante :

« L’importation de la solution : <Le nom> de la solution a échoué. »

Vous pouvez également voir une référence au code d’erreur 80044327. Lorsque vous affichez l’erreur détaillée dans la grille, la colonne détails affiche le message suivant :

« Valeur d’ordre d’affichage non valide. L’ordre d’affichage doit être supérieur ou égal à 10 000 ».

Si vous sélectionnez Télécharger le fichier journal et ouvrez le fichier dans Excel, un message semblable à celui-ci se trouve sous l’onglet Composants :

« 0x80044327
L’ordre 0 du volet de navigation n’est pas autorisé. Il doit être au moins aussi grand que 10000 pour entityRelationshipId <relationshipId> »

Cause

Cette erreur se produit si la solution inclut une relation d’une entité à une autre et que l’ordre d’affichage (NavPaneOrder) est configuré comme un nombre inférieur à 10000. La définition de cette valeur sur un nombre inférieur à 10 000 n’est pas autorisée lors de l’exécution de personnalisations dans Dynamics 365, mais peut être le résultat de la modification directe du customizations.xml.

Résolution

  1. Extrayez le fichier .zip solution que vous essayez d’importer.

  2. Ouvrez le fichier customizations.xml dans un éditeur de texte.

  3. Recherchez une section semblable à l’exemple suivant :

    <NavPaneOrder>0</NavPaneOrder>

    Remarque

    Il est possible que le nombre dans votre exemple soit différent de 0, mais d’un autre nombre inférieur à 10 000. Comme mentionné dans la section Symptômes , vous pouvez faire référence au message dans le fichier journal pour confirmer la valeur de l’ordre du volet de navigation qui a provoqué l’échec.

  4. Après avoir trouvé la section NavPaneOrder non valide, mettez à jour le nombre incorrect avec une valeur supérieure ou égale à 10000.

    Remarque

    N’incluez pas de virgule.

  5. Sélectionnez tous les fichiers de la solution extraite et envoyez-les à un fichier .zip.

  6. Essayez d’importer la solution mise à jour.