Message Accès refusé dans la visionneuse de rapports dans le portail d’entreprise pour Microsoft Dynamics SL

Cet article fournit une solution à un message Accès refusé qui s’affiche lorsque vous essayez d’imprimer ou d’exporter un rapport à l’aide de la visionneuse de rapports sur une page centrale du portail d’entreprise.

S’applique à : Microsoft Dynamics SL 2011
Numéro de la base de connaissances d’origine : 2790389

Symptômes

Lorsque vous essayez d’imprimer ou d’exporter un rapport à l’aide de la visionneuse de rapports sur une page du centre Business Portal, vous pouvez recevoir un message d’erreur semblable au suivant :

Accès refusé. Erreur dans le fichier 6d948fe1-9c3d-4b8b-ae1c-e960e689072d {0CAC72C2-BC49-43B9-83A4-85D206A99313}.rpt : accès au fichier de rapport refusé. Un autre programme peut l’utiliser.

Cause

La visionneuse de rapports n’a pas d’autorisations de lecture sur le répertoire temporaire dans le profil de l’identité du pool d’applications.

Résolution

Créez un profil Windows pour l’identité du pool d’applications sur le serveur web, puis attribuez des autorisations de lecture au groupe Tout le monde au répertoire temporaire contenu dans le profil. Pour ce faire, procédez comme suit :

  1. Connectez-vous au serveur web sur lequel Business Portal est installé à l’aide des informations d’identification Windows de l’identité du pool d’applications associée au site sur lequel Business Portal est installé.

  2. Accédez au répertoire temporaire dans le profil de l’identité du pool d’applications. C:\Users\<USER NAME>\AppData\Local\Temp

  3. Cliquez avec le bouton droit sur le répertoire Temp, puis sélectionnez Propriétés.

  4. Sous l’onglet Sécurité , sélectionnez Modifier , puis Ajouter.

  5. Sélectionnez Emplacements, recherchez le nom du serveur web, puis sélectionnez OK.

  6. Tapez Tout le monde dans la zone Entrez les noms d’objets à sélectionner, puis sélectionnez OK.

  7. Sélectionnez Appliquer , puis OK.

Informations supplémentaires

Pour déterminer le nom de l’utilisateur d’identité pour le pool d’applications utilisé par Business Portal, procédez comme suit :

  1. Sélectionnez Démarrer, Tous les programmes, Outils d’administration, puis Gestionnaire des services Internet (IIS).

  2. Dans le Gestionnaire des services Internet, développez le nom du serveur, puis sélectionnez Pools d’applications.

  3. Cliquez avec le bouton droit sur le nom du pool d’applications associé au site qui héberge Business Portal, sélectionnez Paramètres avancés et notez la valeur Identité .