Erreur « Crystal Print Engine Error 536 » ou « System Message 7014 » lorsque vous essayez d’imprimer ou d’afficher un aperçu avant impression d’un rapport personnalisé dans Microsoft Dynamics SL

Cet article fournit plusieurs solutions à un problème dans lequel vous recevez deux messages d’erreur lorsque vous imprimez ou affichez un aperçu avant impression d’un rapport personnalisé.

S’applique à : Microsoft Dynamics SL
Numéro de la base de connaissances d’origine : 897023

Symptômes

Lorsque vous imprimez un rapport personnalisé ou affichez un aperçu d’un rapport personnalisé avant de l’imprimer dans Microsoft Dynamics SL, les messages d’erreur suivants s’affichent :

Erreur du moteur d’impression Crystal : 536-Error in File. Impossible de se connecter : paramètres d’ouverture de session incorrects.

Message système 7014 : Échec de l’exécution du rapport avec l’erreur 536.

Cause

Ce problème se produit pour une ou plusieurs des raisons suivantes.

Cause 1

Le paramètre Connexion approuvée dans le fichier de rapport est défini sur 1. Voir Résolution 1.

Cause 2

La connexion ODBC (Open Database Connectivity) sur la station de travail est endommagée. Voir Résolution 2.

Cause 3

Le rapport pointe vers deux bases de données différentes. Voir Résolution 3.

Cause 4

Le compte de connexion E7F575915A2E4897A517779C0DD7CE dans SQL Server 2005 ou dans SQL Server 2008 est désactivé ou a un mot de passe incorrect. Voir Résolution 4.

Résolution

Pour résoudre ce problème, utilisez la résolution appropriée.

Résolution 1

Pour résoudre ce problème, définissez le paramètre Connexion approuvée dans le fichier de rapport sur 0 (zéro). Pour ce faire, procédez comme suit :

  1. Démarrez Crystal Reports 10 pour Solomon.

  2. Sélectionnez Ouvrir, sélectionnez le rapport personnalisé, puis sélectionnez Ouvrir.

  3. Dans le menu Base de données , sélectionnez Définir l’emplacement de la source de données.

  4. Dans la boîte de dialogue Définir l’emplacement de la source de données, développez Source de données actuelle : Propriétés.

  5. Sous Source de données actuelle : Propriétés, recherchez le paramètre Connexion approuvée : 1 .

    Remarque

    Si le paramètre Connexion approuvée n’est pas répertorié, l’option Connexion approuvée n’a pas été sélectionnée lors de la création du rapport, et ce n’est pas la cause de l’erreur.

  6. Cliquez avec le bouton droit sur Connexion approuvée : 1, puis sélectionnez Modifier.

  7. Tapez 0.

  8. Sélectionnez Fermer.

  9. Sélectionnez Enregistrer.

Résolution 2

Pour résoudre ce problème, supprimez les connexions ODBC Microsoft Dynamics SL. Ensuite, laissez Microsoft Dynamics SL recréer les connexions. Pour ce faire, procédez comme suit :

  1. Sélectionnez Démarrer, Panneau de configuration, Outils d’administration, puis Sources de données (ODBC).
  2. Sous l’onglet DSN utilisateur , supprimez tous les éléments qui pointent vers vos bases de données d’application Microsoft Dynamics SL.
  3. Sous l’onglet DSN système , supprimez tous les éléments qui pointent vers vos bases de données d’application Microsoft Dynamics SL.
  4. Réexécutez le rapport dans Microsoft Dynamics SL. Les connexions ODBC sont automatiquement recréées lorsque vous exécutez un rapport dans Microsoft Dynamics SL.

Résolution 3

Pour résoudre ce problème, réinitialisez la source de données dans Crystal Reports. Pour ce faire, procédez comme suit :

  1. Démarrez Crystal Reports 10 pour Solomon.
  2. Sélectionnez Ouvrir, sélectionnez le rapport personnalisé, puis sélectionnez Ouvrir.
  3. Dans le menu Base de données , sélectionnez Définir l’emplacement de la source de données.
  4. Dans la zone Remplacer par, développez Créer une connexion, puis ODBC (RDO).
  5. Sélectionnez votre base de données Microsoft Dynamics SL, puis sélectionnez Suivant.
  6. Entrez vos informations de connexion. Ne cochez pas la case Connexion approuvée case activée.
  7. Sélectionnez Terminer.
  8. Sélectionnez la base de données dans la zone Remplacer par . Ensuite, sélectionnez la base de données dans la zone Source de données actuelle .
  9. Sélectionnez Mettre à jour.
  10. Si vous avez plusieurs bases de données dans la zone Source de données actuelle , répétez les étapes 8 et 9 pour chaque base de données.
  11. Sélectionnez Enregistrer, puis quittez Crystal Reports.

Résolution 4

Pour résoudre ce problème, activez le compte de connexion E7F575915A2E4897A517779C0DD7CE dans SQL Server 2005 ou dans SQL Server 2008, puis exécutez le scénario De mise à jour Synchroniser toutes les propriétés & Sécurité dans l’écran Maintenance de base de données (98.290.00) de Microsoft Dynamics SL. Pour ce faire, procédez comme suit :

  1. Démarrez SQL Server Management Studio, puis connectez-vous au serveur qui héberge les bases de données Microsoft Dynamics SL.
  2. Dans le volet Explorateur d'objets, développez Sécurité, puis Connexions.
  3. Sous Connexions, cliquez avec le bouton droit sur E7F575915A2E4897A517779C0DD7CE, puis sélectionnez Propriétés.
  4. Dans le volet Sélectionner une page , sélectionnez État, puis sélectionnez Activé sous Connexion.
  5. Sélectionnez OK, puis fermez SQL Server Management Studio.
  6. Dans Panneau de configuration, sélectionnez Outils d’administration, puis Microsoft Dynamics SL Database Maintenance.
  7. Connectez-vous au instance de SQL Server qui héberge les bases de données Microsoft Dynamics SL.
  8. Sélectionnez l’onglet Mettre à jour la base de données .
  9. Dans la liste Scénarios de mise à jour , sélectionnez Synchroniser toutes les propriétés & sécurité, puis mettre à jour la base de données.
  10. En bas de l’écran Maintenance de la base de données (98.290.00), vérifiez que la barre de progression est terminée, puis sélectionnez Fermer.