Outlook ne se connecte pas ou les services web ne fonctionnent pas après la migration vers Microsoft 365

Symptômes

Une fois votre boîte aux lettres migrée vers Microsoft 365, vous pouvez rencontrer les problèmes suivants :

  • Outlook ne peut pas se connecter à Exchange Server.

  • Vous ne pouvez pas utiliser de fonctionnalités telles que l’absence du bureau, la disponibilité des réunions, les conseils de messagerie, l’archivage en ligne ou toute autre fonctionnalité de services web qui s’appuie sur la découverte automatique.

  • Le message d’erreur suivant s’affiche lorsque vous ouvrez Outlook :

    Outlook ne peut pas se connecter. Vérifiez que vous êtes connecté au réseau et que vous utilisez le serveur et le nom de boîte aux lettres appropriés. Le service d’informations Microsoft Exchange dans votre profil ne contient pas les informations requises. Modifiez votre profil pour vous assurer que vous utilisez le service d’informations Microsoft Exchange approprié.

Cause

Ce problème se produit lorsque le nom du serveur de découverte automatique de prémigration est mis en cache dans votre profil Outlook dans le Registre.

Résolution

Pour résoudre ce problème, appliquez l’une des méthodes suivantes.

Méthode 1 : Utiliser ExcludeLastKnownGoodUrl pour empêcher Outlook d’utiliser la dernière URL de découverte automatique correcte connue

Configurez l’une des sous-clés de Registre suivantes comme suit :

HKEY_CURRENT_USER\Software\Microsoft\Office\<x.0>\Outlook\Autodiscover
DWORD : ExcludeLastKnownGoodUrl
Valeur : 1

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\<x.0>\Outlook\Autodiscover
DWORD : ExcludeLastKnownGoodUrl
Valeur : 1

Remarque

L’espace <réservé x.0> représente votre version d’Office (16.0 = Office 2016, Microsoft 365 et Office 2019, 15.0 = Office 2013).

Lorsque la valeur ExcludeLastKnownGoodUrl est définie sur 1, Outlook n’utilise pas la dernière URL de découverte automatique opérationnelle connue.

Méthode 2 : Créer un profil Outlook

  1. Quittez Outlook.

  2. Dans Panneau de configuration, sélectionnez ou double-cliquez sur Courrier.

    Remarque

    Pour localiser l’élément Courrier, ouvrez Panneau de configuration, puis dans la zone Rechercher en haut de la fenêtre, tapez Courrier. Dans Panneau de configuration de Windows XP, tapez Courrier dans la zone Adresse.

  3. Cliquez sur Afficher les profils.

  4. Sélectionnez Ajouter.

  5. Tapez un nom pour le profil, puis sélectionnez OK.

  6. Suivez l’Assistant Ajouter un compte pour ajouter votre compte de messagerie. Lorsque vous avez terminé, sélectionnez Terminer.

  7. Dans Courrier, assurez-vous que l’option Toujours utiliser ce profil est sélectionnée, puis sélectionnez votre nouveau nom de profil dans la liste.

    Création d’un profil Outlook.

  8. Sélectionnez OK.

Informations supplémentaires

Si vous préférez, vous pouvez utiliser stratégie de groupe pour contrôler si Outlook utilise la dernière URL de découverte automatique connue. Pour cela, procédez comme suit :

  1. Téléchargez le modèle Office stratégie de groupe approprié pour votre version d’Office à partir du site web Microsoft suivant :

    Office 2016 : Fichiers de modèle d’administration Office 2016 (ADMX/ADML) et Outil de personnalisation Office
    Office 2013 : Fichiers de modèle d’administration Office 2013 (ADMX/ADML) et Outil de personnalisation Office

  2. Ajoutez les fichiers Outlk#.admx et Outlk##.adml à votre contrôleur de domaine.

    Remarque

    Pour charger les fichiers de modèle d’administration, téléchargez les fichiers, puis suivez les instructions pour « Chargement des modèles ADMX » dans Utiliser stratégie de groupe pour appliquer les paramètres Office 2010. Bien que cet article cible Office 2010, les informations sur les modèles d’administration s’appliquent également aux versions ultérieures d’Office.

    L’espace ## réservé représente votre version d’Office (16 = Office 2016, Microsoft 365 et Office 2019, 15 = Office 2013).

  3. Sous Configuration utilisateur, développez Modèles d’administration, développez votre version de Microsoft Outlook, développez Paramètres du compte, puis sélectionnez Exchange.

  4. Sous Exchange, recherchez et double-cliquez sur le paramètre Désactiver la découverte automatique .

    Capture d’écran de Outlook 2016 :

    Désactivez l’objet autodiscover stratégie de groupe pour Outlook 2016.

    Capture d’écran d’Outlook 2013 :

    Désactivez le paramètre de stratégie de groupe de découverte automatique pour Outlook 2013.

  5. Sélectionnez Activé, puis, dans le volet Options , sélectionnez Exclure la dernière URL correcte connue.

    L’option Exclure la dernière URL correcte connue.

  6. Sélectionnez OK.