La solution importée précédemment échoue lors de la désinstallation ou de la mise à niveau avec l’erreur « Le rôle avec l’ID est requis par la solution »

Une solution qui a été importée dans une version précédente (par exemple, dans Dynamics CRM) échoue lors de la désinstallation/mise à niveau avec un message d’erreur similaire à « Role » avec id [RoleID] est requise par la solution [SolutionName]. Cet article fournit une solution à ce problème.

S’applique à : Microsoft Dynamics CRM
Numéro de la base de connaissances d’origine : 4025516

Symptômes

Avant une mise à niveau vers la mise à jour de décembre 2016 pour Microsoft Dynamics 365, une solution contenant un rôle personnalisé est installée. Après la mise à niveau de l’organisation, la solution ne peut plus être désinstallée/mise à niveau en raison d’une dépendance entre le rôle et une autre solution, le plus souvent la solution Système. Ce problème n’est pas introduit ou provoqué par l’utilisateur.

Cause

Dans Microsoft Dynamics 365, les flux de processus métier (FBP) sont représentés par des entités de première classe qui adhèrent au modèle de sécurité Microsoft Dynamics 365 comme toute autre entité. Ces entités sont générées lors de la mise à niveau de décembre 2016 vers Microsoft Dynamics 365. Pour vous assurer que tous les rôles existants disposent de l’accès approprié aux BPF, les privilèges BPF sont automatiquement attribués aux rôles existants pendant la mise à niveau. Dans certains cas, ces attributions de privilèges peuvent entraîner des dépendances incorrectes entre les solutions.

Résolution

  1. Dans Microsoft Dynamics 365, accédez à Paramètres>Rôles de sécurité>. Sélectionnez ensuite le rôle de sécurité qui apparaît dans l’erreur et ouvrez l’onglet Flux de processus métier .

  2. Notez les privilèges attribués pour les fichiers BPF. Une capture d’écran est utile, car il s’agit d’une représentation visuelle.

  3. Effacez tous les privilèges, puis enregistrez les modifications. Cela devrait supprimer les dépendances problématiques.

    Remarque

    Vous ne pourrez peut-être pas modifier les privilèges si le rôle fait partie d’une solution et est marqué comme non personnalisable. Si la solution n’est pas managée, vous pouvez mettre à jour la propriété managée personnalisable du rôle et continuer. Dans le cas d’une solution managée, contactez Support Microsoft pour rendre le rôle personnalisable.

  4. Réaffectez les privilèges précédemment attribués, puis enregistrez et fermez la boîte de dialogue. Cela garantit que l’accès requis aux différents rôles est conservé.

Il peut y avoir des dépendances entre plusieurs rôles et solutions. Dans ce cas, effectuez les étapes précédentes pour chacun des rôles signalés avec des problèmes.