Symptôme

Avant une mise à niveau vers la mise à jour de décembre 2016 pour Dynamics 365, une solution qui contient un rôle personnalisé est installée. Après la mise à niveau de l’organisation, la solution ne peut plus être désinstallé/mise à niveau en raison d’une dépendance entre le rôle et une autre solution, plus la solution du système. Ce problème n’est pas introduit ou générée par l’utilisateur.

Cause

Dans Dynamics 365, le flux des processus métiers (BPFs) sont représentés par des entités de première classes qui adhèrent au modèle de sécurité Dynamics 365 comme toute autre entité. Ces entités sont générées pendant le 2016 décembre mise à niveau vers Dynamics 365. Pour garantir que tous les rôles existants ont l’accès approprié aux BPFs, privilèges des BPF sont automatiquement affectés à des rôles existants au cours de la mise à niveau. Dans certains cas, ces affectations de privilège peuvent entraîner des dépendances incorrectes entre les solutions.

Résolution

  1. Dans Dynamics 365, accédez à paramètres > sécurité > rôles de sécurité. Sélectionnez le rôle de sécurité qui s’affiche dans l’erreur, puis ouvrez l’onglet flux des processus métiers.

  2. Prenez note des privilèges qui vous sont affectées dans les BPFs. Une capture d’écran est utile, car il s’agit d’une représentation visuelle.

  3. Désactivez tous les privilèges, puis enregistrez les modifications. Cela doit supprimer les dépendances qui pose problème.
    Remarque: vous ne pourrez pas modifier les privilèges du rôle fait partie d’une solution et est marqué comme non personnalisable. Si la solution est non gérée, vous pouvez mettre à jour« Personnalisable » géré la propriété du rôle et de la continuer. Dans le cas d’une solution gérée, contactez le Support Microsoft pour rendre le rôle personnalisable.

  4. Réaffecter les privilèges qui a été précédemment affectés, puis enregistrement et fermez la boîte de dialogue. Cela garantit que l’accès requis aux différents rôles sont conservées.

Il peut exister des dépendances entre plusieurs rôles et les solutions. Dans ce cas, effectuez les étapes précédentes pour chacun des rôles qui sont signalés des problèmes.

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