Microsoft Dynamics CRM client Outlook peut ne plus répondre en mode non administrateur

Cet article vous aide à contourner le problème qui se produit lorsque vous essayez d’ouvrir Microsoft Dynamics CRM Client pour Outlook ou lorsque vous essayez le processus de synchronisation hors connexion dans le client Microsoft Dynamics CRM pour Outlook avec accès hors connexion.

S’applique à : Microsoft Dynamics CRM 2013 Service Pack 1, Microsoft Dynamics CRM 2015 Microsoft CRM client pour Microsoft Office Outlook
Numéro de la base de connaissances d’origine : 3106337

Symptômes

Lorsque vous essayez d’ouvrir Microsoft Dynamics CRM Client pour Outlook ou lorsque vous essayez le processus de synchronisation hors connexion dans le client Microsoft Dynamics CRM pour Outlook avec accès hors connexion, vous pouvez rencontrer des erreurs telles que les suivantes :

Outlook ne répond plus (clignotement) et vous devez arrêter le processus

Outlook affiche une erreur : aucun point de terminaison à net.pipe://localhost/WebFormService/{random-guid-number} l’écoute n’a pu accepter le message. Cela est souvent dû à une adresse ou une action SOAP incorrecte. Pour plus d’informations, consultez InnerException, le cas échéant.

Cause

Le client CRM pour Outlook s’appuie sur Windows Communication Foundation (WCF) pour communiquer avec un service hors processus afin de s’interfacer avec le serveur CRM. La liaison WCF utilisée est net.pipe qui a un moyen particulier de nommer le canal nommé sous-jacent. À compter de WCF 4.0, le processus de nommage et d’inscription de l’URI du point de terminaison net.pipe est hiérarchique et à deux niveaux : le mode non administratif et le mode administratif. Si un processus inscrit l’URI net.pipe://localhost, tous les processus non administratifs ne pourront accéder à aucun autre service avec une liaison net.pipe, y compris la signature du service de formulaire web local CRM.

Résolution

Il n’y a pas de solution, car c’est la conception. Les services WCF ne doivent pas avoir d’URI d’écouteur sur net.pipe://localhost/. Toutefois, il existe deux solutions de contournement si la situation est vraie.

Pour savoir quel processus maintient l’écouteur sur net.pipe://localhost/, suivez les étapes ci-dessous :

  • Charger le handle de l’outil Sysinternals (Handle v4.22)

  • Décompressez Handle.zip dans un dossier (par exemple : c:\sysinternals)

  • Ouvrir cmd.exe en tant qu’administrateur

  • Accédez au dossier où vous avez décompressé Handle.exe (par exemple, cd c:\sysinternals)

  • Ensuite, exécutez la commande suivante :

    handle "net.pipe:EbmV0LnBpcGU6Ly8rLw=="
    
  • S’il existe une correspondance, le nom de l’exécutable et le PID sont indiqués comme exemple de sortie ci-dessous :

    StandAloneService.exe pid: 10724 type: Section 318: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rLw==
    

Solution de contournement

  • Solution de contournement 1

    Recherchez le fichier (ou le service) qui écoute net.pipe://localhost comme indiqué précédemment et arrêtez-le pendant que vous exécutez Outlook.

  • Solution de contournement 2 (moins recommandé)

    Si vous lancez Microsoft Dynamics CRM Clients pour Outlook avec des droits d’administrateur local (cliquez avec le bouton droit sur Outlook et sélectionnez Exécuter en tant qu’administrateur), la Microsoft Dynamics CRM Client pour Outlook fonctionne comme conception et vous pouvez utiliser le processus de synchronisation hors connexion sans erreur.