Les rendez-vous, les contacts et les tâches ne peuvent pas être synchronisés pour la boîte aux lettres, car l’utilisateur de la boîte aux lettres ne dispose pas des autorisations suffisantes sur cette boîte aux lettres

Cet article fournit une solution à une erreur qui se produit lorsque vous essayez de tester et d’activer une boîte aux lettres dans Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de la base de connaissances d’origine : 4052824

Symptômes

Lorsque vous essayez de tester et d’activer une boîte aux lettres dans Dynamics 365, l’alerte suivante est journalisée :

« Les rendez-vous, les contacts et les tâches ne peuvent pas être synchronisés pour le nom> de la boîte aux lettres<, car l’utilisateur de la boîte aux lettres ne dispose pas des autorisations suffisantes sur cette boîte aux lettres.

Code d’erreur du serveur Email : Crm.80048306.Privilège insuffisant pour accéder à l’objet Microsoft Dynamics 365 ou effectuer l’opération demandée. »

Si vous choisissez d’afficher les détails, les détails supplémentaires suivants s’affichent :

« T :195
ActivityId : <GUID>
>Exception : Exception non gérée : Microsoft.Crm.CrmSecurityException : SecLib ::AccessCheckEx a échoué. Retour de hr = -2147187962, ObjectID : <GUID>, OwnerId : <GUID>, OwnerIdType : 8 et CallingUser : <GUID>. ObjectTypeCode : 4120, objectBusinessUnitId : <GUID>, AccessRights : WriteAccess at Microsoft.Crm.BusinessEntities.SecurityLibrary.AccessCheckEx2(ExecutionContext context, Principal SecurityPrincipal, propriétaire SecurityPrincipal, Guid objectId, Int32 objectTypeCode, Guid objectBusinessUnitId, AccessRights rights) sur Microsoft.Crm.Asynchrone.EmailConnector.ExchangeSyncUtility.HasExchangeSyncIdMappingAccess(Guid userId, Int32 userIdTypeCode, IACTProviderContext orgContext) à l’adresse Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncWorker.PerformPreMailboxSyncChecks() à l’adresse Microsoft.Crm.Asynchrone.EmailConnector.ExchangeS...

Cause

L’utilisateur Dynamics 365 associé à la boîte aux lettres ne dispose pas des privilèges suffisants. Cela est souvent dû au fait que l’utilisateur n’a pas de rôle de sécurité attribué ou que son rôle de sécurité ne dispose pas d’un accès en lecture ou en écriture au niveau de l’utilisateur à l’entité Boîte aux lettres.

Importante

Vérifiez que le propriétaire de l’enregistrement de boîte aux lettres est identique à l’utilisateur. Exemple : si la boîte aux lettres est une boîte aux lettres utilisateur pour Paul Cannon, vérifiez que la valeur Propriétaire dans l’enregistrement de boîte aux lettres de Paul Cannon s’affiche sous la forme Paul Cannon. S’il s’agit d’un autre utilisateur, il se peut que cet utilisateur n’ait pas accès à la boîte aux lettres de cet utilisateur.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. En tant qu’utilisateur disposant du rôle Administrateur système, ouvrez l’enregistrement de boîte aux lettres dans Dynamics 365.

    Remarque

    L’alerte inclut un lien vers l’enregistrement de boîte aux lettres.

  2. Vérifiez que le champ Propriétaire du formulaire de boîte aux lettres est rempli avec le nom de l’utilisateur. Si un autre utilisateur est répertorié, modifiez-le pour qu’il soit identique à cet utilisateur.
  3. Sélectionnez le lien dans le champ Propriétaire pour ouvrir l’enregistrement Utilisateur de l’utilisateur propriétaire.
  4. Sélectionnez Gérer les rôles pour voir quel(s) rôle(s) de sécurité est attribué à cet utilisateur.
  5. Accédez à Paramètres, sélectionnez Sécurité, puis rôles de sécurité.
  6. Ouvrez les rôles trouvés à l’étape 4. Consultez L’erreur PrivilegeDenied se produit lors de l’utilisation de la synchronisation Server-Side pour obtenir la liste des privilèges requis et vérifier que le rôle de sécurité de l’utilisateur contient ces privilèges.
  7. Après avoir vérifié que l’utilisateur est le propriétaire de son enregistrement de boîte aux lettres et que son rôle de sécurité contient les privilèges requis, sélectionnez à nouveau le bouton Tester & Activer la boîte aux lettres dans son enregistrement de boîte aux lettres. Si le test n’aboutit pas à la réussite, passez en revue le message qui s’affiche dans la section Alertes.