Contacts, tâches et rendez-vous ne peut pas être synchronisés pour la boîte aux lettres car l’utilisateur de boîte aux lettres n’a pas les autorisations suffisantes sur cette boîte aux lettres

Symptôme

Lorsque vous essayez de tester et d’activer une boîte aux lettres dans Dynamics 365, l’alerte suivante est enregistrée :

« Rendez-vous, contacts, tâches et ne peut pas être synchronisés pour la boîte aux lettres < nom de boîte aux lettres > car l’utilisateur de boîte aux lettres n’a pas les autorisations suffisantes sur cette boîte aux lettres.

Code d’erreur serveur de messagerie : CRM.80048306.not suffisamment du privilège d’accès le Dynamics 365 Microsoft à objet ou effectuer l’opération demandée. »

Si vous cliquez sur pour afficher les détails, les détails supplémentaires suivants sont affichés :

T:195 « ActivityId : < GUID > > exception : Exception non gérée : Microsoft.Crm.CrmSecurityException : SecLib::AccessCheckEx a échoué. A renvoyé hr =-2147187962, ObjectID : < GUID >, OwnerId : < GUID >, OwnerIdType : 8 et CallingUser : < GUID >. ObjectTypeCode : objectBusinessUnitId de 4120, : < GUID >, AccessRights : WriteAccess à Microsoft.Crm.BusinessEntities.SecurityLibrary.AccessCheckEx2 (ExecutionContext contexte SecurityPrincipal principal, SecurityPrincipal ownerPrincipal, ObjectId de GUID, objectTypeCode de Int32, Guid objectBusinessUnitId, AccessRights droits) à Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncUtility.HasExchangeSyncIdMappingAccess (Guid userId, Int32, userIdTypeCode, IACTProviderContext orgContext) à Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncWorker.PerformPreMailboxSyncChecks() à Microsoft.Crm.Asynchronous.EmailConnector.ExchangeS... »

Cause

L’utilisateur de Dynamics 365 associé à la boîte aux lettres ne dispose pas de privilèges suffisants. Ceci est souvent dû à l’utilisateur n’ayant ne pas un rôle de sécurité attribué ou leur rôle de sécurité est manquant, lecture de niveau utilisateur ou des accès en écriture à l’entité de boîte aux lettres.

IMPORTANT :Vérifier le propriétaire de l’enregistrement de la boîte aux lettres est le même que l’utilisateur. Exemple : Si la boîte aux lettres est une boîte aux lettres d’utilisateur de Paul Cannon, vérifiez la valeur du propriétaire de l’enregistrement de la boîte aux lettres pour Paul Cannon en tant que Paul Cannon. S’il s’agit d’un autre utilisateur, cet utilisateur n’aient pas accès à la boîte aux lettres de cet utilisateur.

Résolution

  1. En tant qu’utilisateur avec le rôle d’administrateur système, ouvrez l’enregistrement de la boîte aux lettres dans Dynamics 365. Remarque : Le message d’alerte inclut un lien vers l’enregistrement de la boîte aux lettres.

  2. Vérifiez que le champ sur le formulaire de la boîte aux lettres propriétaire est rempli avec le nom de l’utilisateur. Si un autre utilisateur n’est répertorié, modifier pour être le même que cet utilisateur.

  3. Cliquez sur le lien dans le champ propriétaire pour ouvrir l’enregistrement de l’utilisateur pour l’utilisateur propriétaire.

  4. Cliquez sur Gérer les rôles pour voir quels rôles de sécurité sont attribuée à cet utilisateur.

  5. Accédez aux paramètreset cliquez sur sécurité, puis cliquez sur Rôles de sécurité.

  6. Ouvrez les rôles trouvées à l’étape 4. Voir la rubriquecet articlepour obtenir la liste des privilèges requis et vérifiez le rôle de sécurité utilisateur contient ces privilèges.

  7. Après vérification de l’utilisateur est le propriétaire de l’enregistrement de la boîte aux lettres et de leur rôle de sécurité indique les privilèges requis, cliquez de nouveau sur le bouton de Test et activer la boîte aux lettres dans leur enregistrement de boîte aux lettres. Si le test n’aboutit pas à succès, examinez le message qui s’affiche dans la section alertes.

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