Applies ToBizTalk Server Developer 2010 BizTalk Server Enterprise 2010 BizTalk Server Standard 2010 BizTalk Server 2013 Branch BizTalk Server 2013 Developer BizTalk Server 2013 Enterprise BizTalk Server 2013 Standard

Symptômes

Supposons que vous utilisez Microsoft BizTalk Server 2010 ou 2013. Lorsque vous utilisez un composant de pipeline personnalisé pour appeler le Service de Transformation du Bus de Service d’entreprise (ESB) pour transformer les messages ESB Shared Computer Toolkit 2.1, la propriété de contexte DocumentSpecName est définie correctement sur le message de sortie, et vous recevez le message d’erreur suivant :

Nom du journal : ApplicationSource : BizTalk ServerL’ID d’événement : 5720Catégorie de tâche : BizTalk ServerNiveau : erreurDescription : il y a un échec de l’exécution du pipeline d’envoi : « ESBTransform.SendPipeline1, ESBTransform, Version = 1.0.0.0, Culture = neutral, PublicKeyToken = ca09cc62b15919a7 » Source : Port d’envoi « Plat assembleur de fichier » : « <SendPortName > » URI : « <SendPortURI> » raison : le type de document « http://ESBTransform.FlatFileSchema1#TargetRoot » ne correspond à aucun des schémas donnés.

Cause

Le problème se produit car le Service de Transformation d’ESB ne définit pas la propriété de contexte DocumentSpecName du message en sortie pour être le type de schéma cible après la transformation.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique.Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n’apparaît pas, soumettez une demande au Service Clients et Support de Microsoft pour obtenir le correctif.Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web Microsoft suivant :

http://support.microsoft.com/contactus/?ws=supportRemarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Informations de mise à jour cumulative

Ce problème a été tout d’abord été résolu dans la mise à jour cumulative suivante de BizTalk Server 2013 :

Conditions préalables

Pour appliquer ce correctif, vous devez disposer de BizTalk ESB Shared Computer Toolkit 2.1 est installé.

Nécessite un redémarrage

Vous n’êtes pas obligé de redémarrer l’ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Microsoft.Practices.ESB.Itinerary.Services.dll

2.1.1.0

24576

13-Oct-2014

13:11

x86

Plus d'informations

Pour plus d’informations sur la terminologie de mise à jour de logiciel, voir terminologie standard qui est utilisé pour décrire les mises à jour logicielles de Microsoft.

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

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