Résolution des erreurs dans Business Portal pour Microsoft Dynamics SL

Cet article fournit une solution aux erreurs qui se produisent lorsque vous essayez d’accéder à Business Portal pour Microsoft Dynamics SL ou d’accéder à l’une des pages web du portail d’entreprise.

S’applique à : Microsoft Dynamics SL 2011
Numéro de la base de connaissances d’origine : 2788387

Symptômes

Lorsque vous essayez d’accéder à Business Portal pour Microsoft Dynamics SL ou d’accéder à l’une des pages web du portail d’entreprise, vous pouvez recevoir une erreur qui ressemble à l’un des messages suivants :

Erreur du serveur dans l’application « / ».
Erreur d’exécution
Description : une erreur d’application s’est produite sur le serveur. Les paramètres d’erreur personnalisés actuels pour cette application empêchent l’affichage à distance des détails de l’erreur d’application (pour des raisons de sécurité). Toutefois, il peut être affiché par les navigateurs s’exécutant sur l’ordinateur serveur local.

Une erreur inattendue s’est produite.
Résoudre les problèmes liés à l’ID de corrélation Microsoft Sharepoint Foundation : xxxxxxxx-xxxx-xxxx-xxxxxxxxxxxx

Cause

Il y a un problème avec Business Portal. Toutefois, le message reçu ne décrit pas correctement le problème.

Résolution

Pour recevoir un message plus descriptif qui peut vous aider à résoudre les problèmes, modifiez le fichier web.config. Pour ce faire, procédez comme suit :

  1. Sur le serveur hébergeant le site web Business Portal, accédez au répertoire inetpub sur le serveur BP.

  2. Recherchez le fichier web.config (généralement dans le C:\inetpub\wwwroot\wss\VirtualDirectories\80 dossier ).

  3. Effectuez une copie de sauvegarde du fichier web.config.

  4. Ouvrez le fichier web.config dans le Bloc-notes.

  5. Recherchez la valeur Callstack="False » et remplacez-la par Callstack="True ».

  6. Recherchez la valeur CustomErrors mode= « On » et remplacez-la par CustomErrors mode="Off ».

  7. Enregistrez le fichier Web.config.

  8. Pour activer les modifications dans le fichier Web.config, exécutez la iisreset commande . Pour ce faire, procédez comme suit :

    1. Sur le serveur sur lequel Business Portal est installé, sélectionnez Démarrer, puis Exécuter.

    2. Tapez la commande suivante dans la zone Ouvrir , puis appuyez sur Entrée :

      iisreset
      
  9. Accédez au portail d’entreprise ou à la page web et notez le message généré.