L’erreur « La culture n’est pas prise en charge » se produit lors de la tentative de configuration de Microsoft Dynamics CRM pour Microsoft Office Outlook

Cet article vous aide à résoudre un problème dans lequel vous obtenez l’erreur « La culture n’est pas prise en charge » lorsque vous tentez de configurer Microsoft Dynamics CRM pour Microsoft Office Outlook.

S’applique à : Microsoft Dynamics CRM 2011, Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2013 Service Pack 1, Microsoft Dynamics CRM 2015, Microsoft CRM client pour Microsoft Office Outlook
Numéro de la base de connaissances d’origine : 2668553

Symptômes

Lorsque vous essayez de vous connecter Microsoft Dynamics CRM pour Microsoft Office Outlook, le message d’erreur suivant s’affiche :

Il y a un problème de communication avec le serveur Microsoft Dynamics CRM. Le serveur n’est peut-être pas disponible. Veuillez réessayer plus tard. Si le problème persiste, contactez votre administrateur système.

La culture n’est pas prise en charge.
Nom du paramètre : culture
0 (0x0000) est un identificateur de culture non valide.
sur Microsoft.Crm.MapiStore.DataStore.WaitInitialized()
Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.InitializeMapiStoreForFirstTime()
Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
Microsoft.Crm.Application.Outlook.Config. ConfigEngine.Configure(object stateInfo)

Cause

Le paramètre de langue n’a pas pu être défini au niveau de l’utilisateur dans CRM en raison de privilèges utilisateur insuffisants. Le rôle de sécurité de l’utilisateur peut ne pas avoir le privilège d’écriture pour l’entité Paramètres utilisateur .

Résolution

  1. Connectez-vous à l’application web Microsoft Dynamics CRM en tant qu’utilisateur avec le rôle Administrateur système.

  2. Accédez à Paramètres Rôles>de sécurité>.

    Remarque

    Si vous n’utilisez pas Microsoft Dynamics CRM 2015 ou version ultérieure, les rôles de sécurité se trouvent sous Administration au lieu de Sécurité.

  3. Ouvrez le rôle attribué à cet utilisateur.

  4. Cliquez sur l’onglet Gestion de l’entreprise et accordez le privilège « Écriture » pour l’entité Paramètres utilisateur . L’accès au niveau de l’utilisateur est la condition minimale requise.

  5. Cliquez sur Save (Enregistrer).

  6. Essayez de vous connecter à nouveau Microsoft Dynamics CRM pour Microsoft Office Outlook.

Si vous rencontrez toujours des problèmes pour connecter CRM pour Outlook à votre organization CRM Online, un outil de diagnostic est disponible pour vous aider à diagnostiquer le problème :

Diagnostic de configuration CRM pour Outlook

Informations supplémentaires

Si vous ne savez pas quel rôle de sécurité est attribué à l’utilisateur, procédez comme suit :

  1. Accédez à Paramètres Sécurité>>Utilisateurs.

    Remarque

    Si vous n’utilisez pas Microsoft Dynamics CRM 2015 ou version ultérieure, utilisateurs se trouve sous Administration au lieu de Sécurité.

  2. Ouvrez l’enregistrement Utilisateur confronté à ce problème.

  3. Dans la barre de commandes de l’enregistrement utilisateur, cliquez sur Gérer les rôles.

  4. Recherchez le rôle de sécurité qui a une coche en regard de celui-ci. Utilisez les étapes fournies dans la section Résolution pour accorder le privilège d’écriture pour l’entité Paramètres utilisateur .