Une erreur « La boîte aux lettres n’a pas d’adresse e-mail valide » se produit lors de l’utilisation de la synchronisation Server-Side

Cet article vous aide à résoudre un problème dans lequel vous obtenez l’erreur « La boîte aux lettres n’a pas d’adresse e-mail valide » lors de l’utilisation de la synchronisation Server-Side dans Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics CRM 2016
Numéro de la base de connaissances d’origine : 3214684

Symptômes

Lorsque vous testez et activez une boîte aux lettres dans Dynamics 365, vous rencontrez l’une des erreurs suivantes dans la zone Alertes :

Les rendez-vous, les contacts et les tâches ne peuvent pas être synchronisés, car le nom> de la boîte aux lettres <n’a pas d’adresse e-mail valide. Spécifiez une adresse e-mail valide dans l’enregistrement de boîte aux lettres, puis activez la boîte aux lettres pour la synchronisation des rendez-vous, des contacts et des tâches.

code d’erreur du serveur Email : Exchange.server a renvoyé l’erreur ErrorNonExistentMailbox.

Une erreur générale d’accès aux boîtes aux lettres s’est produite lors de l’envoi du message électronique « Votre boîte aux lettres est maintenant connectée à Dynamics 365 ». La boîte aux lettres [Nom de la boîte aux lettres] n’a pas été synchronisée. Le propriétaire du profil de serveur de messagerie associé Microsoft Exchange Online a été averti.

code d’erreur du serveur Email : le serveur Exchange a renvoyé l’exception ErrorInvalidOperation.

Email ne peut pas être reçu pour la boîte aux lettres [Nom de la boîte aux lettres], car l’enregistrement de la boîte aux lettres n’a pas d’adresse e-mail valide. La boîte aux lettres n’a pas été synchronisée. Une notification à ce sujet est publiée sur le mur des alertes pour le propriétaire du profil de serveur de messagerie Microsoft Exchange Online.

code d’erreur du serveur Email : Exchange.server a renvoyé l’erreur ErrorNonExistentMailbox.

Cause

Cette erreur peut survenir pour l’une des raisons suivantes :

  • La boîte aux lettres de l’utilisateur est introuvable, car l’adresse e-mail n’est pas correcte.
  • L’adresse e-mail est destinée à un groupe de distribution, qui n’est pas une boîte aux lettres.
  • La boîte aux lettres est configurée pour utiliser un profil Exchange Online, mais la boîte aux lettres de l’utilisateur se trouve dans Exchange en local

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Vérifiez que l’adresse de messagerie de l’enregistrement de boîte aux lettres dans Dynamics 365 correspond à l’adresse de messagerie dans Exchange. L’erreur inclut un lien vers l’enregistrement de boîte aux lettres dans Dynamics 365. Vous pouvez utiliser ce lien pour vérifier rapidement le champ Adresse Email.
  2. Vérifiez que l’adresse e-mail correspond à une boîte aux lettres réelle et non à un groupe de distribution. Les groupes de distribution ne sont pas des boîtes aux lettres qui stockent des e-mails. Les groupes de distribution sont utilisés pour distribuer des e-mails aux boîtes aux lettres qui sont membres du groupe.
  3. Si la boîte aux lettres de l’utilisateur se trouve dans Exchange en local, vérifiez que vous utilisez un profil Exchange Server (hybride) dans Dynamics 365 au lieu d’un profil Exchange Online.

Informations supplémentaires

Lorsque vous cliquez sur Afficher les détails, vous voyez les détails de l’erreur comme suit :

>Erreur : <ResponseMessageType xmlns :q1="https://schemas.microsoft.com/exchange/services/2006/messages » p2 :type="q1 :FindItemResponseMessageType » ResponseClass="Error » xmlns :p2="https://www.w3.org/2001/XMLSchema-instance"q1>< :MessageText>Mailbox n’existe pas.</q1 :MessageText><q1 :ResponseCode>ErrorNonExistentMailbox</q1 :ResponseCode><q1 :DescriptiveLinkKey>0</q1 :DescriptiveLinkKey></ResponseMessageType>

>Erreur : <ResponseMessageType xmlns :q1="https://schemas.microsoft.com/exchange/services/2006/messages » p2 :type="q1 :ItemInfoResponseMessageType » ResponseClass="Error » xmlns :p2=""https://www.w3.org/2001/XMLSchema-instance"><q1 :MessageText>SendOnly ne peut pas être utilisé par un utilisateur sans boîte aux lettres. Utilisez SendAndSaveCopy et spécifiez un ID de dossier dans une boîte aux lettres pour envoyer un élément à partir d’un compte qui n’a pas de boîte aux lettres.</q1 :MessageText><q1 :ResponseCode>ErrorInvalidOperation</q1 :ResponseCode><q1 :DescriptiveLinkKey>0</q1 :DescriptiveLinkKey><q1 :Items /></ResponseMessageType>