Erreur de portail MIM « impossible de traiter votre demande » après l’application des mises à jour de SharePoint Server

Symptômes

Après l’installation de l’une des mises à jour de SharePoint Server suivantes, les pages du portail Microsoft Identity Manager (MIM) ne s’affichent pas :

Pour plus d’informations, voir les pages dupliquées dans SharePoint ne pas afficher

Cause

Le niveau de sécurité des pages dupliquées SharePoint a été amélioré par les scripts côté serveur et les contrôles Insafe forbidding. Dans la mesure où le portail MIM utilise les scripts côté serveur, ses pages ne peuvent pas être rendues.

Solution de contournement

Pour contourner ce problème jusqu’à la publication du prochain correctif MIM, ajoutez un nouvel élément PageParserPath ayant un attribut virtualPath au fichier Web. config sous l’élément configuration/SharePoint/safemode/PageParserPaths , comme suit :

     <SafeMode MaxControls="200" CallStack="false" DirectFileDependencies="10" TotalFileDependencies="250" AllowPageLevelTrace="false">           <PageParserPaths>                <PageParserPath VirtualPath="/identitymanagement/*" CompilationMode="Always" AllowServerSideScript="true" IncludeSubFolders="True"/>           </PageParserPaths>      </SafeMode>

Références

Historique des versions du gestionnaire d’identité Microsoft

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.

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