L’erreur « Exception interdite renvoyée par le serveur HTTP » s’affiche dans la boîte aux lettres microsoft Dynamics 365

Cet article fournit une solution à une erreur qui se produit lorsque vous sélectionnez le bouton Tester & Activer la boîte aux lettres sur un enregistrement de boîte aux lettres dans Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de la base de connaissances d’origine : 4483440

Symptômes

Lorsque vous sélectionnez le bouton Tester & Activer la boîte aux lettres sur un enregistrement de boîte aux lettres dans Dynamics 365, la section des résultats du test affiche Échec et l’alerte suivante est journalisée :

« Impossible d’envoyer le message électronique « Votre boîte aux lettres est maintenant connectée à Dynamics 365 », car une erreur s’est produite lors de l’établissement d’une connexion sécurisée au serveur de messagerie. La boîte aux lettres [Nom de la boîte aux lettres] n’a pas été synchronisée. Le propriétaire du profil de serveur de messagerie Microsoft Exchange Online a été averti.
Email Code d’erreur du serveur : Le serveur HTTP a renvoyé l’exception Interdit. »

Si vous sélectionnez Détails, les autres détails suivants s’affichent :

« Erreur : System.Net.WebException : La requête a échoué avec http status 403 : Interdit.
sur System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
sur System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
sur Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
sur Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem() »

Cause

Dynamics 365 communique avec Microsoft Exchange à l’aide de requêtes EWS (Exchange Web Services). Si EWS est désactivé, cette erreur se produit. Le contenu suivant présente certaines façons potentielles de désactiver ou de restreindre EWS dans Exchange :

  1. EWS est désactivé pour la boîte aux lettres
  2. EWS est désactivé pour l’ensemble de la organization
  3. Est EwsApplicationAccessPolicy défini sur EnforceAllowList et the EwsAllowList n’autorise pas l’accès à partir de Dynamics 365 (CRM).
  4. est EwsApplicationAccessPolicy défini sur EnforceBlockList et the EwsBlockList inclut Dynamics 365 (CRM).

Résolution

Si le problème se produit uniquement pour certaines boîtes aux lettres, case activée si EWS est désactivé pour la boîte aux lettres :

  1. Tout d’abord, case activée pour voir si EWS a été désactivé pour la boîte aux lettres. Utilisez la commande PowerShell suivante :

    Get-CASMailbox <mailbox-alias> | ft EwsEnabled
    
  2. Si EwsEnabled a la valeur False, utilisez la commande PowerShell suivante pour activer les services web Exchange (EWS) pour la boîte aux lettres :

    Set-CASMailbox <mailbox-alias> -EwsEnabled $True
    

    Importante

    Après l’exécution de cette commande, la modification du paramètre peut prendre jusqu’à 120 minutes.

Si le problème se produit pour toutes les boîtes aux lettres, case activée si EWS est désactivé au niveau organization ou si EwsAllowList est utilisé pour limiter le trafic EWS autorisé.

  1. Utilisez la commande PowerShell suivante pour voir si l’un des paramètres EWS est configuré :

    Get-OrganizationConfig |ft Name, EwsEnabled,EwsApplicationAccessPolicy,EwsBlockList,EwsAllowList
    
  2. Vérifiez que EwsEnabled n’est pas défini sur False. La commande suivante peut être utilisée pour définir EwsEnabled sur True si elle est actuellement définie sur False :

    Set-OrganizationConfig -EwsEnabled $True
    

    Importante

    Après l’exécution de cette commande, la modification du paramètre peut prendre jusqu’à 120 minutes.

  3. Si EwsApplicationAccessPolicy a la valeur EnforceAllowList et EwsAllowList ne contient pas de valeur pour CRM (exemple : CRM/*), ce qui empêcherait Dynamics 365 (CRM) de communiquer avec Exchange. Utilisez la commande suivante pour mettre à jour la liste afin d’inclure CRM/* et les autres applications que vous souhaitez autoriser (<PreviousAllowList> dans l’exemple suivant) :

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceAllowList -EwsAllowList:CRM/*,<PreviousAllowedList>
    

    Importante

    Après l’exécution de cette commande, la modification du paramètre peut prendre jusqu’à 120 minutes.

  4. Si EwsApplicationAccessPolicy est défini sur EnforceBlockList et EwsAllowList contient une valeur pour CRM (exemple : CRM/*), ce qui empêcherait Dynamics 365 (CRM) de communiquer avec Exchange. Utilisez la commande suivante pour mettre à jour la liste afin de ne plus inclure CRM :

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceBlockList -EwsBlockList:<PreviousBlockList WITH CRM REMOVED>
    

    Importante

    Après l’exécution de cette commande, la modification du paramètre peut prendre jusqu’à 120 minutes.

Plus d’informations

Pour plus d’informations sur la modification des paramètres Exchange à l’aide de PowerShell et le contrôle de l’accès à EWS, consultez les articles suivants :