Symptôme

Lorsque vous cliquez sur le bouton de Test et d’activer la boîte aux lettres sur un enregistrement de boîte aux lettres dans Dynamics 365, la section de résultats de test indique la défaillance et l’alerte suivante est enregistrée :

« Le message « votre boîte aux lettres est maintenant connecté à Dynamics 365 » ne peut pas être envoyé car une erreur s’est produite lors de l’établissement d’une connexion sécurisée avec le serveur de messagerie. Boîte aux lettres [nom de la boîte aux lettres] n’a pas synchroniser. Le propriétaire du profil de serveur de messagerie Microsoft Exchange Online a été averti.

Code d’erreur de serveur de messagerie : serveur Http a retourné l’exception de l’interdit. »

Si vous cliquez sur Détails, les détails supplémentaires suivants sont affichés :

« Erreur : System.Net.WebException : la demande a échoué avec l’état HTTP 403 : interdit.    à System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse (message de SoapClientMessage, réponse de WebResponse, responseStream de flux, Boolean asyncCall)    à System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke (IAsyncResult asyncResult)    à Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem (IAsyncResult asyncResult)    au Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem() »

Cause

Dynamics 365 communique avec Microsoft Exchange à l’aide de demandes de Exchange Web Services (EWS). Si EWS est désactivé, cette erreur se produit. Voici quelques méthodes EWS peuvent être désactivées ou limitées dans Exchange :

  1. EWS est désactivé pour la boîte aux lettres

  2. EWS est désactivé pour l’ensemble de l’organisation

  3. Le EwsApplicationAccessPolicy a la valeur EnforceAllowList et l’EwsAllowList ne permet pas l’accès à partir de Dynamics 365 (CRM).

  4. Le EwsApplicationAccessPolicy a la valeur EnforceBlockList et le EwsBlockList comprend des Dynamics 365 (CRM).

Résolution

Si le problème ne se produit que pour des boîtes aux lettres, vérifiez si EWS est désactivé pour la boîte aux lettres :

  1. Vérifiez d’abord si EWS a été désactivée pour la boîte aux lettres. Utilisez la commande PowerShell suivante : Get-CASMailbox < alias de boîte aux lettres > | texte intégral EwsEnabled

  2. Si EwsEnabled est défini sur False, utilisez la commande PowerShell suivante pour activer Exchange Web Services (EWS) pour la boîte aux lettres : Set-CASMailbox < alias de boîte aux lettres > - EwsEnabled $True IMPORTANT : Après avoir exécuté cette commande, il peut prendre jusqu'à 120 minutes avant que le changement de paramètre prenne effet.

Si le problème se produit pour toutes les boîtes aux lettres de transfert, vérifiez si EWS est désactivé au niveau de l’organisation ou si la EwsAllowList est utilisée pour limiter le trafic EWS autorisé.

  1. Utilisez la commande PowerShell suivante pour voir si les paramètres EWS sont configurés : Get-OrganizationConfig | nom de ft, EwsEnabled, EwsApplicationAccessPolicy, EwsBlockList, EwsAllowList

  2. Vérifiez que EwsEnabled n’est pas la valeur False. La commande suivante peut être utilisée pour EwsEnabled la valeur True si elle est actuellement définie sur False : Set-OrganizationConfig - EwsEnabled $True IMPORTANT : Après avoir exécuté cette commande, il peut prendre jusqu'à 120 minutes avant que le changement de paramètre prenne effet.

  3. Si EwsApplicationAccessPolicy est défini sur EnforceAllowList et le EwsAllowList ne contient-elle pas une valeur pour CRM (exemple : CRM / *), cela empêcherait Dynamics 365 (CRM) d’être en mesure de communiquer avec Exchange. Utilisez la commande suivante pour mettre à jour la liste pour inclure CRM / * et les autres applications que vous souhaitez autoriser (< PreviousAllowList > dans l’exemple suivant) : Set-OrganizationConfig - EwsApplicationAccessPolicy : EnforceAllowList - EwsAllowList : CRM / *, < PreviousAllowedList > IMPORTANT : Après avoir exécuté cette commande, il peut prendre jusqu'à 120 minutes avant que le changement de paramètre prenne effet.

  4. Si EwsApplicationAccessPolicy est défini sur EnforceBlockList et EwsAllowList contient une valeur pour CRM (exemple : CRM / *), cela empêcherait Dynamics 365 (CRM) d’être en mesure de communiquer avec Exchange. Utilisez la commande suivante pour mettre à jour la liste pour ne plus inclure CRM : Set-OrganizationConfig - EwsApplicationAccessPolicy : EnforceBlockList - EwsBlockList : < PreviousBlockList avec CRM supprimé > IMPORTANT : Après avoir exécuté cette commande, il peut prendre jusqu'à 120 minutes avant que le changement de paramètre prenne effet.

Informations supplémentaires

Consultez les articles suivants pour plus d’informations sur la modification des paramètres Exchange à l’aide de PowerShell et contrôle de l’accès à EWS :

Exchange Server PowerShell (Exchange Management Shell) https://docs.Microsoft.com/PowerShell/Exchange/Exchange-Server/Exchange-Management-shell?view=Exchange-PS

Se connecter à Exchange Online PowerShell https://docs.Microsoft.com/PowerShell/Exchange/Exchange-Online/Connect-to-Exchange-Online-PowerShell/Connect-to-Exchange-Online-powershell?view=Exchange-PS

Contrôle l’accès à EWS dans Exchange https://docs.Microsoft.com/Exchange/client-Developer/Exchange-Web-Services/How-to-Control-Access-to-EWS-in-Exchange

Set-CASMailbox https://docs.Microsoft.com/PowerShell/module/Exchange/Client-Access/Set-casmailbox?view=Exchange-PS

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