Erreur « Impossible d’ouvrir votre message crypté » lorsque des utilisateurs externes essaient d’ouvrir les messages cryptés

Symptômes

Lorsque vous essaient d’afficher le contenu d’un message crypté à partir de votre organisation aux utilisateurs externes, ils reçoivent le message d’erreur suivant lorsqu’ils ont entré le mot de passe unique :

Désolé, nous ne pouvons pas afficher votre message maintenant
Quelque chose s’est passé et votre message crypté n’a pas pu être ouvert. Essayez à nouveau en suivant les instructions fournies dans le message d’origine dans les 5 minutes.

Cause

Ce problème se produit si votre configuration inclut une combinaison de la plus ancienne basée sur Exchange Office Message cryptage (lle) et le service de chiffrement Azure la Protection des informations plus récent.

Résolution

Pour résoudre ce problème, appliquez l’une des méthodes suivantes.
 

Méthode 1

La méthode la plus simple est de forcer le système à lle version 1. Pour ce faire, exécutez la commande suivante :

Set-IRMConfiguration -AzureRMSLicensingEnabled $False

Maintenant, les nouveaux messages sont chiffrés à l’aide de la Règle de Transport fonctionnent reçus par des destinataires externes.
 

Méthode 2

Une méthode plus efficace est de suivre ces étapes :

  1. Assurez-vous que toutes les étapes d’implémentation sont terminées. Pour ce faire, reportez-vous à configurer de nouvelles fonctions de cryptage des messages Office 365 basées sur la Protection des informations Azure.

  2. Modifier l’action de la Règle de Transport pour Appliquer la Protection de droitset sélectionnez le modèle de Ne pas transférer .

Pour plus d’informations sur la Protection des informations Azure, consultez Activation de la gestion des droits Azure.

Plus d'informations

Pour déterminer si votre configuration inclut une combinaison de lle et Protection des informations Azure, procédez comme suit :

  1. Exécuter l’applet de commande get-irmconfiguration et vérifiez si la valeur du paramètre AzureRMSLicensingEnabled est définie sur True.

  2. Examiner la règle de transport qui crypte le message pour voir s’il s’agit de la «crypter le message avec le cryptage des messages Office 365» action.

Si les deux conditions sont réunies, votre configuration est combinant les deux types de technologies de cryptage Microsoft. Dans ce cas, le destinataire externe ne sera jamais en mesure d’ouvrir les messages.

Remarque Les résultats que vous obtenez à partir de l’applet de commande test-irmconfiguration sont très différents pour chaque version d’IRM. Par conséquent, ces résultats peuvent être utilisé également comme preuve de technologies mixtes. Les réponses complètes pour chaque configuration ne sont pas inclus dans cet article.

Vous pouvez obtenir une preuve supplémentaire que vous êtes dans ce cas en collectant une trace Fiddler de l’échec de la tentative d’accéder au contenu de message qui ne sont pas crypté. L’onglet JSON de la fenêtre de réponse affiche l’un des messages d’erreur suivants :

  • MessageText = l’objet est introuvable dans le magasin, Impossible de décoder le message - itemId : ItemId, currentUser - John@contoso.com

  • Impossible de décoder le message - itemId : ItemId, currentUser - John@contoso.com«, » ResponseCode » : « ErrorRightsManagementPermanentException », « ResponseClass » : « Erreur », « Éléments » : null »


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