L’erreur de chargement du fichier d’importation est trop volumineuse lors de l’importation d’une solution dans Microsoft Dynamics 365

Cet article fournit une solution à une erreur qui se produit lorsque vous essayez d’importer une solution dans Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de la base de connaissances d’origine : 4462491

Symptômes

Lorsque vous essayez d’importer une solution dans Dynamics 365, l’importation échoue et le message suivant s’affiche :

« Le fichier d’importation est trop volumineux pour être chargé.
Code d’erreur 80040375 »

Cause

Bien que le message d’erreur indique un problème avec la taille maximale de la solution à importer, un autre problème tel qu’une erreur SQL peut en être la cause.

Résolution

Sélectionnez le bouton Télécharger le fichier journal pour afficher un message plus détaillé. Vous pouvez voir des détails tels que le message suivant :

L’importation a échoué. Pour plus d’informations, consultez les messages d’erreur associés. : Les noms de colonnes System.Data.SqlClient.SqlException (0x80131904) de chaque table doivent être uniques. Le nom de colonne '<column name>' dans la table '<entity/table name>' est spécifié plusieurs fois.

L’exemple de message ci-dessus est une erreur SQL qui peut se produire si vous essayez d’importer un champ qui existe déjà dans cette entité.

Exemple : si vous avez créé un champ personnalisé dans le organization avec un nom de schéma appelé new_field1 sur l’entité Account. Vous essayez maintenant d’importer une solution qui contient un champ portant le même nom de schéma sur l’entité Account. SQL n’autorise pas plusieurs colonnes portant le même nom dans la même table, ce qui entraîne l’échec de l’importation. Vous pouvez constater que dans l’environnement cible, vous aviez déjà un champ avec le même nom de schéma, mais une casse différente, telle que new_Field1 et le champ dans la solution que vous importez, est new_field1. Si le champ portant le même nom n’est pas nécessaire dans l’environnement cible, supprimez-le, puis réessayez l’importation.

Si l’erreur persiste et que vous n’êtes pas en mesure de résoudre le problème à l’aide des détails du fichier journal, contactez Support Microsoft pour obtenir de l’aide. Vous pouvez également utiliser les informations contenues dans le fichier journal pour rechercher des solutions potentielles dans les communautés Dynamics 365.