Erreur « le fichier d’importation est trop volumineux pour être téléchargé » se produit lors de l’importation d’une solution dans Dynamics 365

Travaillez partout et à partir de n’importe quel appareil avec Microsoft 365

Effectuez une mise à niveau vers Microsoft 365 pour travailler partout avec les dernières fonctionnalités et mises à jour.

Mettre à niveau maintenant

Symptôme

Lorsque vous essayez d’importer une solution dans Dynamics 365, l’importation échoue et le message suivant s’affiche :

« Le fichier d’importation est trop volumineux pour être téléchargé. 

Code d’erreur 80040375"  

Cause

Bien que le message d’erreur indique un problème avec l' importation du fichier est trop volumineux pour être téléchargé, un autre problème, telle qu’une erreur SQL peut être la cause.

Résolution

Cliquez sur le bouton Télécharger le fichier journal pour afficher un message plus détaillé. Vous pouvez voir les détails tels que le message suivant :

« Échec de l’importation. Pour plus d’informations, consultez les messages d’erreur connexes. : System.Data.SqlClient.SqlException (0x80131904) : les noms de colonne de chaque table doivent être uniques. Nom de colonne '< nom de colonne >' dans la table '< nom de l’entité ou de la table >' est spécifié plusieurs fois... »

L’exemple de message ci-dessus est une erreur SQL qui peut se produire si vous essayez d’importer un champ qui existe déjà dans cette entité.

Exemple : Si vous aviez créé un champ personnalisé dans l’organisation avec un nom de schéma appelé new_field1 sur l’entité compte. Maintenant vous essayez d’importer une solution qui contient un champ avec ce même nom de schéma sur l’entité compte. SQL n’autorise pas plusieurs colonnes portant le même nom dans la même table Ceci entraînera l’échec de l’importation. Vous pouvez trouver que dans l’environnement cible, vous avez déjà un champ portant le même nom de schéma, mais une casse différente, telles que new_Field1 et le champ de la solution que vous importez est new_field1. Si le champ avec le même nom n’est pas nécessaire dans l’environnement cible, supprimez-le, puis réessayez l’importation.

Si l’erreur persiste et que vous n’êtes pas en mesure de résoudre le problème en utilisant les détails dans le fichier journal, contactez le Support Microsoft pour obtenir de l’aide. Vous pouvez également utiliser les informations dans le fichier journal pour rechercher des solutions potentielles dans les Communautés de Dynamics 365.

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×