Nous ne parvenons pas à nous connecter à votre erreur de serveur Microsoft Dynamics 365 lors de l’utilisation de Microsoft Dynamics 365 App pour Outlook

Cet article fournit une résolution du problème lié au fait que vous ne pouvez pas utiliser Microsoft Dynamics 365 App pour Outlook en raison de l’erreur Nous ne pouvons pas nous connecter à votre serveur Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de la base de connaissances d’origine : 4341413

Symptômes

Lorsque vous tentez d’utiliser Microsoft Dynamics 365 App pour Outlook, vous recevez le message suivant :

« Nous ne pouvons pas nous connecter à votre serveur Dynamics 365 Microsoft. Essayez de fermer et de rouvrir l’application. »

Si vous sélectionnez Afficher plus, le message suivant peut s’afficher :

« Délai d’expiration du chargeur du client »

Si vous utilisez l’application dans Outlook Web Access (OWA), l’invite suivante peut apparaître en bas de l’écran :

« Voulez-vous autoriser dynamics.com l’utilisation de stockage supplémentaire sur votre ordinateur ? »

Si vous effacez le cache du navigateur Internet Explorer, cette erreur peut sembler résolue, mais elle est finalement retournée.

Cause

Microsoft a connaissance d’un problème où cette erreur peut se produire, car internet Explorer est configuré pour limiter la quantité de données pouvant être mises en cache. Si vous affichez l’application à l’aide d’Internet Explorer, cela peut être la cause de l’erreur. Si vous rencontrez cette erreur à l’aide du Bureau Outlook, Outlook utilise toujours Internet Explorer pour afficher l’application.

Résolution

Microsoft travaille sur une modification pour éviter ce problème. En attendant, vous pouvez utiliser les étapes ci-dessous comme solution de contournement potentielle :

Option 1 : Augmenter la limite de base de données dans les options de Explorer Internet

Selon la version de votre système d’exploitation, vous pourrez peut-être modifier la limite dans les paramètres d’Internet Explorer. Si vous utilisez Windows 10, cette option n’apparaît pas et vous pouvez utiliser l’option 2 à la place.

  1. Ouvrez Internet Explorer.
  2. Dans le coin supérieur droit, sélectionnez l’icône d’engrenage, puis sélectionnez Options Internet.
  3. Sous l’onglet Général de la section Historique de navigation , sélectionnez Paramètres.
  4. Sélectionnez l’onglet Caches et bases de données .
  5. Si vous voyez une option M’avertir quand un cache ou une base de données de site web dépasse , remplacez la valeur par 200 et sélectionnez OK. Vous pouvez également sélectionner dynamics.com dans la liste des sites web, puis sélectionner Dépasser la limite. Si ces options n’apparaissent pas, passez à l’option 2.
  6. Effacez l’historique et le cache des Explorer Internet. Pour obtenir des instructions détaillées, consultez Afficher et supprimer votre historique de navigation dans Internet Explorer.

Option 2 : Augmenter la limite de base de données dans le Registre

Importante

Cette section contient des étapes qui vous indiquent comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, consultez l’article Comment sauvegarder et restaurer le Registre dans Windows.

Pour augmenter la limite de mise en cache autorisée, créez l’entrée de Registre suivante :

Sous-clé : HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
Nom : MaxTrustedDomainLimitInMB
Type : REG_DWORD
Données : 200

Pour créer cette entrée de Registre, procédez comme suit :

  1. Sélectionnez Démarrer, Exécuter, tapez regedit, puis sélectionnez OK.

  2. Recherchez et sélectionnez la sous-clé de Registre suivante. Si le chemin d’accès à cet emplacement n’existe pas, vous devrez peut-être créer les clés mentionnées :

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue

  3. Cliquez avec le bouton droit sur IndexedDBValue, pointez sur Nouveau, puis sélectionnez Valeur DWORD.

  4. Dans la zone Nouvelle valeur #1 , tapez MaxTrustedDomainLimitInMB, puis appuyez sur Entrée.

  5. Cliquez avec le bouton droit sur MaxTrustedDomainLimitInMB, puis sélectionnez Modifier.

  6. Sélectionnez Décimal, tapez 200 , puis sélectionnez OK.

  7. Quittez le Registre Rédacteur, puis redémarrez l’ordinateur.

  8. Effacez l’historique et le cache des Explorer Internet. Pour obtenir des instructions détaillées, consultez Afficher et supprimer votre historique de navigation dans Internet Explorer.

Plus d’informations

Il existe plusieurs causes potentielles pour cette erreur. Si cela ne résout pas le problème, reportez-vous à l’article suivant pour obtenir des solutions potentielles supplémentaires :

Erreur « Nous ne pouvons pas nous connecter à votre serveur Microsoft Dynamics 365 » lors de l’utilisation de Dynamics 365 App pour Outlook