Dégradation des performances dans Microsoft Dynamics CRM en raison d’un grand nombre de fichiers temporaires

Cet article fournit une résolution pour résoudre le problème de dégradation des performances dans Microsoft Dynamics CRM en raison d’un grand nombre de fichiers temporaires.

S’applique à : Microsoft Dynamics CRM 2011
Numéro de la base de connaissances d’origine : 2877070

Symptômes

Vous pouvez rencontrer une dégradation des performances, qui peut survenir soit parce que la solution du KIT de développement logiciel (SDK) est à court de noms de fichiers disponibles, soit parce qu’un programme antivirus effectue des analyses lors de la création des fichiers.

Cause

Il existe une limite de 65 335 fichiers qui peuvent être créés dans le répertoire temporaire Windows et lorsque cette limite est atteinte, les processus qui doivent créer ces fichiers ne peuvent pas le faire, ce qui a un impact sur les performances ou empêche l’application de répondre.

Résolution

Une bonne pratique pour le répertoire temporaire consiste à le faire effacer régulièrement sur le serveur dans le cadre d’une routine de maintenance normale. Il existe de nombreux outils et utilitaires qui peuvent effectuer un nettoyage automatisé.