Impossible d’interagir avec l’application de bureau sans message d’erreur

Cet article fournit une résolution à un problème dans lequel vous ne pouvez pas interagir avec l’application de bureau sans message d’erreur dans Microsoft Power Automate.

S’applique à : Power Automate
Numéro de la base de connaissances d’origine : 5003775

Symptômes

Vous pouvez rencontrer les problèmes suivants :

  1. Les clics de souris ou les séquences de touches ne sont pas envoyés à l’application cible, sans message d’erreur.
  2. L’enregistreur de bureau ne reconnaît pas les éléments de l’application de bureau.

Vérification du problème

Vous pouvez ouvrir le Power Automate pour le bureau Designer et essayer d’interagir avec l’application de bureau avec l’une des actions suivantes :

  • Envoyer des clés
  • Cliquer sur Envoyer la souris
  • Déplacer la souris vers l’image

En outre, ouvrez l’enregistreur Desktop et essayez de capturer un élément dans l’application.

Les deux opérations ci-dessus ne peuvent pas être effectuées sans message d’erreur.

Cause

L’application s’exécute avec plus de privilèges élevés que Power Automate pour le bureau.

Résolution

L’application et Power Automate pour le bureau doivent s’exécuter avec les mêmes privilèges.

Power Automate pour le bureau ne s’exécute pas avec élévation de privilèges par défaut. Par conséquent, décochez la case Exécuter ce programme en tant qu’administrateur dans la section Compatibilité de la fenêtre Propriétés de l’application.

Une autre option consiste à définir Power Automate pour le bureau pour qu’elle s’exécute également en tant qu’administrateur.