L'ID 17659 et l'ID 3859 de l'événement sont enregistrés lorsque vous mettez à jour les tables système dans une base de données SQL Server

Symptômes

Scénario 1 Un événement qui ressemble à ce qui suit est enregistré dans le journal d'erreur du serveur SQL ou dans le journal d'application dans Event Viewer lorsqu'une table système est mise à jour manuellement dans Microsoft SQL Server :

Log Name: ApplicationSource: MSSQL$SQL2008R2Event ID: 17659Task Category: ServerLevel: InformationDescription: Warning: System table ID 34 has been updated directly in database ID 17 and cache coherence may not have been maintained. SQL Server doit être redémarré.

Scénario 2 Un événement qui ressemble à ce qui suit est enregistré dans le journal d'erreur du serveur SQL ou dans le journal d'application dans Event Viewer lorsque vous démarrez une base de données SQL Server qui contient une table système qui a été mise à jour manuellement :

Log Name: ApplicationSource: MSSQL$SQL2008R2Event ID: 3859Task Category: ServerLevel: InformationDescription: Warning: The system catalog was updated directly in database ID 17, most recently at date_time

Scénario 3Le message d'avertissement suivant est retourné lorsque vous exécutez la commande DBCC_CHECKDB après la mise à jour manuelle d'une table système :

Résultats DBCC pour 'database_name'. Vérifier le catalogue Msg 3859, État 1 : Avertissement : Le catalogue du système a été mis à jour directement dans la base de données ID 17, plus récemment à date_time. CHECKDB a trouvé 0 erreurs d'allocation et 0 erreurs de cohérence dans la base de données 'db_name'. Exécution DBCC terminée. Si DBCC a imprimé des messages d'erreur, contactez votre administrateur système.

Cause

Ce problème peut se produire si une table système de base est mise à jour manuellement. Notes (en)

  • La mise à jour manuelle des tables système n'est pas prise en charge. Les tables système ne doivent être mises à jour que par le moteur de base de données SQL Server.

  • Vous pouvez afficher les données dans les tableaux système à travers les vues de catalogue système.

Résolution

Pour résoudre ce problème, transférez le contenu de la base de données qui a été mis à jour manuellement dans une nouvelle base de données pour l'utilisation de l'application.

Informations supplémentaires

Tables de base système Le tableau suivant fournit plus d'informations sur les produits ou outils qui vérifient automatiquement cette condition sur votre instance de SQL Server et sur les versions du produit SQL Server contre laquelle la règle est évaluée.

Logiciel de règle

Titre de règle

Description des règles

Versions de produits contre lesquelles la règle est évaluée

Conseiller System Center

SQL Server a détecté la mise à jour directe du catalogue du système : Msg 17659

System Center Advisor génère une alerte lorsque l'ID 17659 est signalé au journal d'application dans Windows. Utilisez les informations de l'alerte pour identifier la base de données qui est dans un état non pris en charge, et suivez les étapes de la section "Résolution" de cet article.

Serveur SQL 2008SQL Serveur 2008 R2SQL Serveur 2012

Conseiller System Center

SQL Server a détecté la mise à jour directe du catalogue du système : Msg 3859

System Center Advisor génère une alerte lorsque l'ID 3859 est signalé au journal d'application dans Windows. Utilisez les informations de l'alerte pour identifier la base de données qui est dans un état non pris en charge, et suivez les étapes de la section "Résolution" de cet article.

Serveur SQL 2008SQL Serveur 2008 R2SQL Serveur 2012

Références

Pour plus d'informations sur les problèmes qui peuvent se produire lorsqu'une table système de serveur SQL est mise à jour manuellement, cliquez sur le numéro d'article pour afficher l'article dans la base de connaissances Microsoft :

2787112 "Msg 8992" message d'erreur et métadonnées incohérentes dans les catalogues système SQL Server

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×