La fonctionnalité d’utilisation du bureau Outlook ne fonctionne pas correctement dans Office 36

Symptômes

Lorsque vous essayez d’utiliser la fonctionnalité Absence du bureau (OOF) dans Outlook dans Microsoft Office 365, vous pouvez éprouver les symptômes suivants :

  • Le message d’absence du personnel ne peut pas être enregistré.

  • Un ancien message d’absence du travail ou un message d’absence du double est envoyé.

  • Un message d’absence du personnel n’est pas envoyé même si vous activez le message d’absence du message.

Cause

Ce problème se produit pour l’une des raisons suivantes : 

  • Cause 1 :le backlog d’événements de l’Assistant Boîte aux lettres (Exchange 2010 uniquement) est en cours.

  • Cause 2: les modèles de règles d’absence de sécurité sont malformés ou endommagés.

  • Cause 3: le quota des règles d’absence deof est dépassé et de nouvelles règles ne peuvent pas être créées.

  • Cause 4: le paramètre Domaine distant pour le domaine par défaut (ou spécifique) n’est pas réglé pour autoriser les messages OOF.

Résolution

Remarque Une des quatre causes peut entraîner l’échec d’une réponse de l’of. Par conséquent, chaque cause doit être exclue une par une.

AvertissementL’Microsoft Exchange Server’éditeur MAPI (MFCMapi) peut endommager Microsoft Exchange Server boîtes aux lettres du serveur Exchange. Téléchargez MFCMAPI à partir de github (faites défiler vers le bas, puis cliquez sur Dernière version).

Pour résoudre ce problème, suivez les étapes de la cause spécifique. 

Résolution 1

  1. Configurez la fonctionnalité OOF. Pour ce faire, exécutez l’une des cmdlets suivantes Windows PowerShell, le cas échéant :

    Set-MailboxAutoReplyConfiguration <de> -AutoReplyState désactivé

    Set-MailboxAutoReplyConfiguration <identité> -AutoReplyState activé

  2. Utilisez MFCMapi pour vérifier la PR_OOF_STATE valeur. Pour cela, procédez comme suit :

    a.       Dans la fenêtre principale de MFCMapi, cliquez sur Session,puis sur Ouverture de session et sur Afficher la table store pour ouvrir la boîte aux lettres.

    b.      Cliquez sur le profil à consulter, puis faites défiler le volet inférieur jusqu’à ce que la PR_OOF_STATE ajoutée. Cette valeur doit être True si vous avez activé la fonctionnalitéOf dans Windows PowerShell ou False si vous avez désactivé la fonctionnalité OOF. Par exemple, si vous avez désactivé la fonctionnalitéOf, envisagez la capture d’écran suivante :

    texte de remplacement

  3. Si la PR_OOF_STATE n’est pas le résultat attendu, contactez le Support Microsoft pour leur permettre de vérifier la recherche d’événements en file d’attente (Exchange 2010 uniquement).

Résolution 2

RemarqueLes symptômes de votre cas peuvent différer légèrement de ceux-ci. Par exemple, le message d’absence de la vie ne peut pas être envoyé comme prévu, bien que le message d’absence du titre puisse être réglé sans erreur. Toutefois, ces étapes seront toujours applicables.

Pour résoudre ce problème, supprimez les règles d’absence de poste et les modèles de règles d’absence de chez vous de la boîte aux lettres. Ensuite, ré enablez la fonctionnalité OOF et testez le comportement. Pour la modifier, utilisez la clé de Registre AutoRecoverDelay. 

RemarqueIl n’est pas besoin de faire une fois les étapes ci-après avant de suivre ces étapes.

  1. Dans la fenêtre principale de MFCMapi, cliquez sur Session,puis sur Ouverture de session et sur Afficher la table store pour ouvrir la boîte aux lettres.

  2. Développez le conteneur racine et le haut du magasin d’informations.

  3. Supprimez les règles d’absence de la vie. Pour cela, procédez comme suit :
     

    1. Cliquez avec le bouton droit sur Boîte deréception, puis cliquez sur Afficher le tableau des règles.
       

      • Si la fonctionnalitéOf est désactivée, une règle OOF est répertoriée dans le tableau des règles avec le nom de règle suivant : MSFT : Règles D’absence de bureau TDX

      • Si la fonctionnalitéOf est activée, deux règles d’absence de niveau d’absence sont répertoriées dans le tableau des règles. Les règles répertoriées varient selon qu’elles sont activées uniquement en interne ou à la fois en interne et en externe. Par exemple, examinez la capture d’écran suivante :

        texte de remplacement

      • Si les modèles d’absence de travail sont endommagés ou malformés, ceux-ci sont répertoriés dans la table Règles. Vous pouvez voir d’autres entrées si l’utilisateur a activé d’autres règles.

    2. Cliquez avec le bouton droit sur les règles d’absence deof, puis cliquez sur Supprimer.                 Remarque Ne supprimez aucune règle de l’absence de référence à l’exception de celles référencés.

    3. Fermez la fenêtre Table des règles.

  4. Supprimez les modèles d’absence de la page. Pour cela, procédez comme suit :

    • Cliquez avec le bouton droit sur Boîte deréception, puis cliquez sur Ouvrir la table des matières associée.

    • Faites défiler vers le côté droit, puis développez la colonne Classe de message.

    • Pour trier les éléments, cliquez sur la colonne Classe de message.

    • Recherchez les éléments dont la classe message est l’une des valeurs suivantes :

      • IPM. Note.Rules.ExternalOofTemplate.Microsoft

      • IPM. Note.Rules.OofTemplate.Microsoft

Par exemple, prenons la capture d’écran suivante :

  1. texte de remplacement



    • Cliquez avec le bouton droit sur les éléments qui appartiennent à l’une de ces deux classes de message, puis cliquez sur Supprimer le message. 

      Remarque Ne supprimez aucun objet sauf ceux référencés.

      texte de remplacement

    • Dans la boîte de dialogue Supprimer l’élément, sélectionnez Supprimer définitivement DELETE_HARD_DELETE (non remboursable) sous StyleSuppression, puis cliquez sur OK.
      texte de remplacement

    • Désactivez, puis réactivez la fonctionnalité DOF à l’aide des commandes suivantes :

      Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Disabled
      Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Enabled

    • Vérifiez si la fonctionnalité DOF fonctionne comme prévu et que les symptômes ne se produisent plus.

Résolution 3

Si une réponse d’absence de réponse n’est plus renvoyée, il est probable que le quota des règles soit dépassé. Par conséquent, les règles internes et externes de l’absence de contrôle ne peuvent pas être créées. Pour résoudre ce problème, procédez comme suit :

  1. Augmentez votre quota de règles. Pour ce faire, suivez la procédure de l’article suivant de la Base de connaissances Microsoft :

    1. 2622933 Un utilisateur ne peut pas créer de nouvelles règles dans Outlook ou Outlook Web App

  2. En raison de la mise en cache des informations de quota dans le magasin d’informations, l’application des valeurs de quota mises à jour peut nécessiter jusqu’à deux heures.

  3. Répétez la résolution 2.

Résolution 4

Si la valeur AllowedOFFType du domaine distant est Aucune,les messages D’absence de service ne sont pas tirer en externe. Cette valeur doit être définie sur Externe pour autoriser les oufs externes. Par défaut, cette valeur est définie sur Aucune. N’oubliez pas que lorsque vous recherchez dans les domaines distants, la valeur par défaut est terminée par des entrées spécifiques. Par conséquent, si l’utilisateur envoie un message à un utilisateur @contoso.com et qu’il existe une entrée Contoso.com dans les paramètres de domaine distant, la valeur AllowedOOFType est utilisée pour cette entrée spécifique. Si aucune entrée n’est Contoso.com, le domaine distant par défaut (*) est utilisé.


Get-RemoteDomain | select Name,AllowedOOFType

Informations supplémentaires

Si la valeur PR_OOF_STATE n’est pas le résultat attendu, consultez l’article suivant de la Base de connaissances Microsoft :

2705649 Exchange : le traitement des messages et RBA ne fonctionne pas comme prévu dans Exchange 2010

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