Le client Outlook Microsoft Dynamics CRM 2011 ne parvient pas à configurer sur l’adresse web IFD externe

Cet article fournit une résolution du problème lié au fait que les utilisateurs ne peuvent pas configurer le Microsoft Dynamics CRM client Outlook sur l’adresse web externe et que l’erreur Impossible de se connecter à Microsoft Dynamics CRM serveur, car nous ne pouvons pas authentifier vos informations d’identification se produit.

S’applique à : Microsoft Dynamics CRM 2011
Numéro de la base de connaissances d’origine : 2912175

Symptômes

Lorsque le déploiement Microsoft Dynamics CRM 2011 est configuré pour le déploiement accessible sur Internet (IFD) à l’aide des services de certificats Active Directory (ADFS), les utilisateurs peuvent recevoir l’erreur suivante lorsqu’ils tentent de configurer le client Outlook Microsoft Dynamics CRM à l’adresse web externe :

Impossible de se connecter à Microsoft Dynamics CRM serveur, car nous ne pouvons pas authentifier vos informations d’identification. Vérifiez votre connexion ou contactez votre administrateur pour obtenir de l’aide.

Lors de l’examen du journal de configuration, l’exception suivante est également capturée :

Erreur de connexion à l’URL : https://crmorg.domain.com/XRMServices/2011/Discovery.svc Exception : System.ServiceModel.EndpointNotFoundException : aucun point de terminaison à https://adfs.domain.com/adfs/services/trust/13/username l’écoute n’a pu accepter le message .

Toutefois, les utilisateurs peuvent toujours être en mesure d’accéder à l’URL externe via un navigateur web sans erreur.

Cause

Le point de terminaison /adfs/services/trust/13/username peut être activé. Lorsque ce point de terminaison est activé, le client ne peut pas atteindre les points de terminaison mixtes nom d’utilisateur et kerberos, ce qui entraîne l’échec de l’authentification.

Résolution

Désactivez le point de terminaison /adfs/services/trust/13/username et redémarrez le service ADFS. Pour effectuer cette action, consultez les étapes ci-dessous :

  1. Ouvrez la console de gestion AD FS.
  2. Dans le volet de navigation gauche, développez Service, puis sélectionnez Points de terminaison.
  3. Dans la liste des points de terminaison, recherchez et cliquez avec le bouton droit sur le point de terminaison /adfs/services/trust/13/username.
  4. Sélectionnez Désactiver.
  5. Redémarrez le service AD FS.