Symptômes
Lorsque le déploiement de Microsoft Dynamics CRM 2011 est configuré pour Internet IFD Deployment (IFD) à l’aide des Services de certificats Active Directory (ADFS), les utilisateurs peuvent recevoir le message d’erreur suivant lorsque vous essayez de configurer le client Microsoft Dynamics CRM Outlook à l’adresse web externe :
« Impossible de se connecter au serveur de Microsoft Dynamics CRM, car nous ne pouvons pas authentifier vos informations d’identification. Vérifiez votre connexion ou contactez votre administrateur pour obtenir de l’aide. »
Lorsque vous examinez le journal de configuration, l’exception suivante est également capturée :
Erreur de connexion à l’URL : https://crmorg.domain.com/XRMServices/2011/Discovery.svc Exception : System.ServiceModel.EndpointNotFoundException: il n’a aucun point de terminaison à l’écoute sur le http://adfs.domain.com/adfs/services/trust/13/username qui peut accepter le message.
Toutefois, les utilisateurs risquent de toujours pouvoir accéder à l’URL externe via un navigateur web sans erreur.
Cause
Le point de terminaison /adfs/services/trust/13/username peut être activée. Lorsque ce point de terminaison est activé, le client ne pourra pas atteindre les points de terminaison usernamemixed et kerberosmixed, qui entraîne l’échec de l’authentification.
Résolution
Désactiver le point de terminaison /adfs/services/trust/13/username et redémarrez le service ADFS. Pour effectuer cette action, consultez les étapes ci-dessous :
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Ouvrez la Console de gestion d’Active Directory Federation Services
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Dans le volet de navigation de gauche, développez le Service, puis cliquez sur points de terminaison.
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Dans la liste de point de terminaison, recherchez et cliquez sur le point de terminaison /adfs/services/trust/13/username
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Sélectionnez désactiver
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Redémarrez le service AD FS.