Se connecter avec Microsoft
S'identifier ou créer un compte.
Bonjour,
Sélectionnez un autre compte.
Vous avez plusieurs comptes
Choisissez le compte avec lequel vous voulez vous connecter.

Cet article s’applique à Microsoft Dynamics NAV pour tous les pays et tous les paramètres régionaux de langue.

Symptômes

Lorsque vous appliquez une charge importante à la base de données Microsoft Dynamics NAV dans Microsoft Dynamics NAV 2009 Service Pack 1 (SP1), le serveur de Microsoft Dynamics NAV cesse et déconnecte tous les clients personnalisés (/RTCs). Par exemple, lorsque vous exécutez une restauration classique d’une société, ce problème se produit. En outre, un message d’erreur semblable au suivant est enregistré dans le journal d’Application :

Service :
Utilisateur : [domaine] \[utilisateur] Type : System.Data.SqlClient.SqlException
Classe : 11
LineNumber : 0
Numéro : -2
Serveur : (local)
État : 0
Source : fournisseur de données SqlClient .net
Code d’erreur :-2146232060
Message : Le délai d’attente a expiré. Le délai d’attente écoulée avant l’achèvement de l’opération ou le serveur ne répond pas.
StackTrace :
à System.Data.SqlClient.SqlConnection.OnError (SqlException exception, Boolean breakConnection)
à System.Data.SqlClient.SqlInternalConnection.OnError (SqlException exception, Boolean breakConnection)
à System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning (TdsParserStateObject stateObj)
à System.Data.SqlClient.TdsParser.Run (RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
à System.Data.SqlClient.SqlDataReader.ConsumeMetaData()
à System.Data.SqlClient.SqlDataReader.get_MetaData()
à System.Data.SqlClient.SqlCommand.FinishExecuteReader (SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
à System.Data.SqlClient.SqlCommand.RunExecuteReaderTds (CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)
à System.Data.SqlClient.SqlCommand.RunExecuteReader (CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, méthode de chaîne, le résultat de DbAsyncResult)
à System.Data.SqlClient.SqlCommand.RunExecuteReader (CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, méthode de chaîne)
à System.Data.SqlClient.SqlCommand.ExecuteReader (CommandBehavior comportement, méthode de chaîne)
à System.Data.SqlClient.SqlCommand.ExecuteReader()
à Microsoft.Dynamics.Nav.Runtime.NavDatabaseChangeListener.TryExecuteReader()
à Microsoft.Dynamics.Nav.Runtime.NavDatabaseChangeListener.CollectTrackingObjects()
à Microsoft.Dynamics.Nav.Runtime.NavDatabaseChangeListener.TimerHandler (objet param)

Cause

Ce problème se produit car la logique des nouvelles tentatives de l’écouteur de modifications n’effectuent trois tentatives avant d’arrêter le serveur de Microsoft Dynamics NAV. Logique des nouvelles tentatives de l’écouteur de modifications doit être modifiée pour un nombre infini de tentatives afin que le serveur de Microsoft Dynamics NAV n’est pas arrêté.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si vous rencontrez un problème lors du téléchargement, l’installation de ce correctif, ou que vous avez d’autres questions de support technique, contactez votre partenaire ou, si inscrit à un plan de support directement avec Microsoft, vous pouvez contacter le support technique pour Microsoft Dynamics et créer une demande de support. Pour ce faire, visitez le site Web Microsoft suivant :

https://mbs.microsoft.com/support/newst art.aspxVous pouvez également contacter le support technique pour Microsoft Dynamics par téléphone à l’aide de ces liens pour les numéros de téléphone spécifiques des pays. Pour ce faire, reportez-vous à l’un des sites Web Microsoft suivants :

Partenaires

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global +Support+ContactsClients

https://mbs.microsoft.com/customersource/support/information/SupportIn formation/global_support_contacts_eng.htmDans certains cas, les frais généralement encourus pour la prise en charge des appels peuvent être annulés si un technicien du Support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question.



Comment faire pour obtenir le correctif logiciel de Microsoft Dynamics NAV ou mettre à jour des fichiers

Une fois que vous demandez un correctif logiciel de Microsoft Dynamics NAV, un lien hypertexte sera envoyé dans un message électronique pour vous.


Le message électronique contiendra un lien hypertexte et un mot de passe. Vous pouvez utiliser le lien hypertexte pour télécharger le correctif logiciel de Microsoft Dynamics NAV ou les fichiers de mise à jour. Lorsque vous cliquez sur le lien hypertexte, la boîte de dialogue Téléchargement de fichier – Avertissement de sécurité s’ouvre. Puis, vous êtes invité à exécuter, à enregistrer ou à annuler le téléchargement.


Si vous cliquez sur exécuter, les fichiers de démarrer le téléchargement et le processus d’extraction. Vous devez spécifier un dossier pour les nouveaux fichiers et ensuite fournir le mot de passe.


Si vous cliquez sur Enregistrer, vous devez spécifier un chemin d’accès pour enregistrer le fichier compressé. Lorsque vous ouvrez le fichier que vous avez enregistré, vous êtes invité à spécifier un chemin d’accès pour les fichiers. Ensuite, vous devez fournir le mot de passe fourni dans le message électronique.


Si vous cliquez sur Annuler, le processus de téléchargement s’arrête.


Comment installer un correctif Microsoft Dynamics NAV ou un fichier de mise à jour

Les mises à jour et correctifs logiciels de plate-forme Microsoft Dynamics NAV sont accessibles sous forme de fichiers unique. Pour installer un correctif Microsoft Dynamics NAV ou une mise à jour, vous devez remplacer les fichiers d’installation de Microsoft Dynamics NAV existantes avec le correctif ou les mise à jour fichiers. Pour ce faire, procédez comme suit.

Étape 1 : Remplacer les fichiers dans l’installation du Client de Microsoft Dynamics NAV Classic

Dans l’installation de Microsoft Dynamics NAV Classic Client, remplacez les fichiers suivants en utilisant le fichier de correctif ou la mise à jour.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Dbm.dll

6.0.31989.0

427,848

03-Dec-2010

15:34

x86

Fin.exe

6.0.31989.0

12,639,048

03-Dec-2010

15:34

x86

Finhlink.exe

6.0.31989.0

452,432

03-Dec-2010

15:34

x86

Finsql.exe

6.0.31989.0

12,761,424

03-Dec-2010

15:34

x86

Nc_netb.dll

6.0.31989.0

96,592

03-Dec-2010

15:34

x86

Nc_tcp.dll

6.0.31989.0

98,640

03-Dec-2010

15:34

x86

Nc_tcps.dll

6.0.31989.0

141,136

03-Dec-2010

15:34

x86

Ndbcs.dll

6.0.31989.0

1,350,480

03-Dec-2010

15:34

x86

Slave.exe

6.0.31989.0

152,400

03-Dec-2010

15:33

x86

Pour remplacer les fichiers existants de Microsoft Dynamics NAV, procédez comme suit :

  1. Fermez le Client Microsoft Dynamics NAV Classic.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Classic Client. Le Client Microsoft Dynamics NAV Classic est habituellement installé dans le répertoire suivant :

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Copiez les fichiers que vous avez téléchargé.

  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de Microsoft Dynamics NAV Classic Client.

  5. Cliquez sur Oui pour remplacer les fichiers dans le répertoire.

Étape 2 : Remplacer les fichiers dans l’installation du client personnalisé Microsoft Dynamics NAV

Dans l’installation du client personnalisé Microsoft Dynamics NAV, remplacez les fichiers suivants en utilisant le fichier de correctif ou la mise à jour.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Microsoft.dynamics.framework.patterns.dll

1.3.10803.394

71,656

03-Dec-2010

06:30

x86

Microsoft.dynamics.framework.ui.dll

1.3.10803.394

698,328

03-Dec-2010

06:30

x86

Microsoft.dynamics.framework.ui.mapping.dll

1.3.10803.394

104,424

03-Dec-2010

06:30

x86

Microsoft.dynamics.framework.ui.navigation.dll

1.3.10803.394

34 800

03-Dec-2010

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.dll

1.3.10803.394

92,136

03-Dec-2010

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.winforms.dll

1.3.10803.394

63,480

03-Dec-2010

06:30

x86

Microsoft.dynamics.framework.ui.windows.dll

1.3.10803.394

83,944

03-Dec-2010

06:30

x86

Microsoft.dynamics.framework.ui.winforms.controls.dll

1.3.10803.394

2,217,984

03-Dec-2010

06:30

x86

Microsoft.dynamics.framework.ui.winforms.dll

1.3.10803.394

694,256

03-Dec-2010

06:30

x86

Microsoft.dynamics.nav.client.builder.dll

6.0.31989.0

202,640

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.client.exe

6.0.31989.0

149,376

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.client.interop.communicator.dll

1.0.559.183

75,688

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.client.serviceconnection.dll

6.0.31989.0

104,352

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.client.ui.dll

6.0.31989.0

513,920

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.client.winforms.dll

6.0.31989.0

341,904

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.client.winforms.tlb

Ne s'applique pas

2,680

03-Dec-2010

12:15

Ne s'applique pas

Microsoft.dynamics.nav.language.dll

6.0.31989.0

2,000,768

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.types.dll

6.0.31989.0

571,256

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.watson.dll

6.0.31989.0

42,880

03-Dec-2010

15:23

x86

Microsoft.office.interop.outlook.dll

10.0.4504.0

395,136

03-Dec-2010

15:34

x86

Pour remplacer ces fichiers, procédez comme suit :

  1. Fermez le client personnalisé Microsoft Dynamics NAV.

  2. Recherchez le répertoire d’installation client personnalisé Microsoft Dynamics NAV. Le client personnalisé Microsoft Dynamics NAV est habituellement installé dans le répertoire suivant :

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client

  3. Copiez les fichiers que vous avez téléchargé.

  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation client personnalisé Microsoft Dynamics NAV.

  5. Cliquez sur Oui pour remplacer les fichiers dans le répertoire.

Étape 3 : Remplacer les fichiers dans l’installation de Microsoft Dynamics NAV Server

Dans l’installation de Microsoft Dynamics NAV Server, remplacez les fichiers suivants en utilisant le fichier de correctif ou la mise à jour.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Httpcfg.exe

5.2.3790.0

22,352

03-Dec-2010

15:33

x86

Microsoft.dynamics.nav.language.dll

6.0.31989.0

2,000,768

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.ncl.dll

6.0.31989.0

608,120

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.server.exe

6.0.31989.0

141,184

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.service.dll

6.0.31989.0

145,280

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.service.runtime.dll

6.0.31989.0

75,664

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.service.webservices.dll

6.0.31989.0

145,304

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.types.dll

6.0.31989.0

571,256

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.watson.dll

6.0.31989.0

42,880

03-Dec-2010

15:23

x86

Nclcsrt.etx

Ne s'applique pas

89,525

03-Dec-2010

08:32

Ne s'applique pas

Nclcsrt.stx

Ne s'applique pas

91,724

03-Dec-2010

08:32

Ne s'applique pas

Nclcsrts.dll

6.0.31989.0

1,489,232

03-Dec-2010

15:33

x86

Ndbcs.dll

6.0.31989.0

1,350,480

03-Dec-2010

15:33

x86

Pour remplacer ces fichiers, procédez comme suit :

  1. Arrêter le de Microsoft Dynamics NAV Server.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Server. Le de Microsoft Dynamics NAV Server est habituellement installé dans le répertoire suivant :

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Copiez les fichiers que vous avez téléchargé.

  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de Microsoft Dynamics NAV Server.

  5. Cliquez sur Oui pour remplacer les fichiers dans le répertoire.

  6. Démarrer le de Microsoft Dynamics NAV Server.

Étape 4 : Remplacer les fichiers dans l’installation de Microsoft Dynamics NAV Application Server.

Si vous avez installé Microsoft Dynamics NAV Application Server, remplacez les fichiers suivants dans l’installation de Microsoft Dynamics NAV Application Server en utilisant le correctif ou les mise à jour fichiers.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Dbm.dll

6.0.31989.0

427,848

03-Dec-2010

15:34

x86

Nas.exe

6.0.31989.0

2,270,024

03-Dec-2010

15:34

x86

Nassql.exe

6.0.31989.0

2,368,848

03-Dec-2010

15:34

x86

Ndbcs.dll

6.0.31989.0

1,350,480

03-Dec-2010

15:34

x86

Slave.exe

6.0.31989.0

152,400

03-Dec-2010

15:34

x86

Pour remplacer les fichiers, procédez comme suit.

  1. Arrêtez le serveur d’Application Microsoft Dynamics NAV.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server est habituellement installé dans le répertoire suivant :

    C:\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Copiez les fichiers que vous avez téléchargé.

  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de Microsoft Dynamics NAV Application Server.

  5. Cliquez sur Oui pour remplacer les fichiers dans le répertoire.

  6. Démarrez le serveur d’Application Microsoft Dynamics NAV.

Étape 5 : Remplacer les fichiers dans l’installation du Kit de développement Microsoft Dynamics NAV

Si vous avez Microsoft Dynamics NAV SDK est installé, remplacez les fichiers suivants.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Cf.h

Ne s'applique pas

57,736

03-Dec-2010

12:15

Ne s'applique pas

Cfront.dll

6.0.31989.0

1,578,320

03-Dec-2010

15:33

x86

Cfront.ocx

6.0.31989.0

111,952

03-Dec-2010

15:33

x86

Cfrontsql.dll

6.0.31989.0

1,788,248

03-Dec-2010

15:33

x86

Libload.c

Ne s'applique pas

31,718

03-Dec-2010

06:51

Ne s'applique pas

Microsoft.dynamics.nav.cfront.cfrontdotnet.dll

6.0.31989.0

182,168

03-Dec-2010

15:23

x86

Microsoft.dynamics.nav.cfront.cfrontdotnet.xml

Ne s'applique pas

442,447

03-Dec-2010

07:13

Ne s'applique pas

Sample.c

Ne s'applique pas

28,718

03-Dec-2010

06:51

Ne s'applique pas

Sample.exe

6.0.31989.0

152,400

03-Dec-2010

15:33

x86

Pour remplacer les fichiers, procédez comme suit.

  1. Localisez les répertoires d’installation de kit de développement Microsoft Dynamics NAV. Le Kit de développement logiciel de Microsoft Dynamics NAV est généralement installé dans les répertoires suivants :

    C:\Program Files\Microsoft Dynamics NAV\60\SDK\CFRONT

    Composants de C:\Program Files\Microsoft Dynamics NAV\60\SDK\Communication

    Composant de C:\Program Files\Common Files\Microsoft Dynamics NAV\Communication

  2. Choisissez le Kit de développement logiciel pour mettre à jour, C/Front ou composants de Communication.

  3. Copiez les fichiers que vous avez téléchargé.

  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de Microsoft Dynamics NAV SDK approprié.

  5. Cliquez sur Oui pour remplacer les fichiers dans le répertoire.

Remarque Si vous avez téléchargé un correctif ou une mise à jour pour les composants de communication, vous devez enregistrer les fichiers .dll individuellement.

Étape 6 : Remplacer les fichiers dans l’installation du pilote ODBC de Microsoft Dynamics NAV

Si vous avez le pilote ODBC de Microsoft Dynamics NAV, remplacez les fichiers suivants dans l’installation du pilote ODBC de Microsoft Dynamics NAV.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Cfront.dll

6.0.31989.0

1,578,320

03-Dec-2010

15:34

x86

Dbm.dll

6.0.31989.0

427,848

03-Dec-2010

15:34

x86

Nc_netb.dll

6.0.31989.0

96,592

03-Dec-2010

15:34

x86

Nc_tcp.dll

6.0.31989.0

98,640

03-Dec-2010

15:34

x86

Nc_tcps.dll

6.0.31989.0

141,136

03-Dec-2010

15:34

x86

Nodbc.dll

6.0.31989.0

2,141,008

03-Dec-2010

15:34

x86

Nodbc.xml

Ne s'applique pas

1,209

25-Aug-2009

16:43

Ne s'applique pas

Nodbccfg.cfg

6.0.31989.0

724,480

03-Dec-2010

08:05

Ne s'applique pas

Nodbccfg.xml

Ne s'applique pas

2,472

25-Aug-2009

16:43

Ne s'applique pas

Slave.exe

6.0.31989.0

152,400

03-Dec-2010

15:34

x86

Pour remplacer les fichiers, procédez comme suit.

  1. Recherchez le répertoire d’installation du pilote ODBC de Microsoft Dynamics NAV. Le pilote ODBC de Microsoft Dynamics NAV est habituellement installé dans le répertoire suivant :

    C:\Program Files\Microsoft Dynamics NAV\60\ODBC

  2. Copiez les fichiers que vous avez téléchargé.

  3. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de pilote ODBC de Microsoft Dynamics NAV.

  4. Cliquez sur Oui pour remplacer les fichiers dans le répertoire.

Conditions préalables

Vous devez disposer de Microsoft Dynamics NAV 2009 Service Pack 1 pour appliquer ce correctif.

État

Microsoft a confirmé qu'il s'agissait d'un bogue dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft

Remarque Il s’agit d’un article de « Dernière minute » créé directement à partir de l’organisation de support technique de Microsoft. Les informations contenues dans ce document sont fournies en l'état, en réponse à des problèmes nouveaux. En raison de la rapidité de leur mise à disposition, les documents peuvent contenir des erreurs typographiques et peuvent être révisés à tout moment sans préavis. Consultez les Conditions d’utilisation pour d’autres considérations.

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.

Les communautés vous permettent de poser des questions et d'y répondre, de donner vos commentaires et de bénéficier de l'avis d'experts aux connaissances approfondies.

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?
En cliquant sur Envoyer, vos commentaires seront utilisés pour améliorer les produits et services de Microsoft. Votre administrateur informatique sera en mesure de collecter ces données. Déclaration de confidentialité.

Nous vous remercions de vos commentaires.

×