Le service hôte de l’Agent SMS ne démarre pas après le redémarrage d’un ordinateur client de Systems Management Server 2003

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description du Registre Microsoft Windows

Symptômes

Après le redémarrage d’un ordinateur client de Microsoft Systems Management Server (SMS) 2003, le service hôte de l’Agent SMS (Ccmexec.exe) ne démarre pas. Lorsque ce problème se produit, les entrées d’erreur semblables aux suivants peuvent apparaître dans le fichier journal CCMExec.log sur l’ordinateur client SMS :

Entrée de fichier journal CCMExec.log 1

Démarrage CCMEXEC service... $$ < CcmExec >< ven fév 13 8:13:13.819 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >
En cours d’exécution sur l’ordinateur nom_ordinateur en tant qu’utilisateur système.
$$ < CcmExec >< ven fév 13 8:13:13.859 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >
ERREUR ! WBEM introuvable dans le chemin d’accès système. $$ < CcmExec >< ven fév 13 8:13:13.859 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >
WBEM ajouté à la variable d’environnement PATH du processus. $$ < CcmExec >< ven fév 13 8:13:13.859 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >
Lors de l’initialisation de COM. $$ < CcmExec >< ven fév 13 8:13:13.859 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >
L’inscription pour la consignation des notifications de modification. $$ < CcmExec >< ven fév 13 8:13:13.869 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >
Définition de composant d’enregistrement par défaut pour le processus. $$ < CcmExec >< ven fév 13 8:13:13.869 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >
Définir le statut du service comme en cours d’exécution. $$ < CcmExec >< ven fév 13 8:13:13.869 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >
Vérifier si une réparation est nécessaire. $$ < CcmExec >< ven fév 13 8:13:13.889 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >
Impossible d’ouvrir à WMI espace de noms '\\.\root\ccm' (80004002) $$ < CcmExec >< ven fév 13 8:13:17.224 une heure d’hiver Central 2004 >< thread = 1216 (0x4C0) >Entrée de fichier journal CCMExec.log 2

25/1/2006 9:16:35 PMFailed à ouvrir à l’espace de noms WMI '\\.\root\ccm' (8004100a)
25/1/2006 9:16:35 PMCCMDoCertificateMaintenance a échoué (0x8004100a).
25/1/2006 9:16:35 PMFailed à ouvrir à l’espace de noms WMI '\\.\root\CCM\Events' (8004100a)
25/1/2006 9:16:35 PMCCMDoCertificateMaintenance() a déclenché l’événement d’état CCM_ServiceHost_CertificateOperationsFailure.
25/1/2006 9:16:35 PMLoading les paramètres de service.
25/1/2006 9:16:35 PMFailed à ouvrir à l’espace de noms WMI '\\.\root\ccm\Policy\Machine' (8004100a)
25/1/2006 9:16:35 PMError chargement des paramètres de service. Code 0x8004100a
25/1/2006 9:16:35 (0x8004100a) Échec de l’initialisation de PMPhase 0.
25/1/2006 9:16:35 (0x8004100a) Échec de l’initialisation de PMService.
25/1/2006 9:16:35 PMShutting AdditonallyCCMEXEC vers le bas...En outre, le fichier Wbemcore.log peut contenir une entrée d’erreur semblable au suivant :

(Ven fév 13 08:13:13 2004.69289) : entrée de Registre indique un programme d’installation est en cours d’exécution.
(Ven fév 13 08:14:13 2004.129856) : construction de CFactory
(Ven fév 13 08:14:13 2004.129886) : CFactory de CAPACITE de destruction
(Ven fév 13 08:14:13 2004.129896) : WINMGMT_ACTIVE de créer mutex
(Ven fév 13 08:14:13 2004.129946) : lecture des informations de configuration à partir du Registre
(Ven fév 13 08:14:16 2004.132800) : préparation d’une demande d’init d’espace de noms pour l’espace de noms actif //./ROOT/ccm/policy
(Ven fév 13 08:14:16 2004.132901) : préparation d’une demande d’init d’espace de noms pour l’espace de noms actif //./root/CIMV2
(Ven fév 13 08:14:16 2004.132961) : préparation d’une demande d’init d’espace de noms pour l’espace de noms actif //./root/subscription
(Ven fév 13 08:14:16 2004.133021) : l’initialisation d’espace de noms //./ROOT/ccm/policy
(Ven fév 13 08:14:16 2004.133041) : l’initialisation d’espace de noms //./root

Cause

Ce problème se produit lorsque l’une ou les deux conditions suivantes sont remplies :

  • La variable de chemin d’accès %SystemRoot%\System32\Wbem ne figure pas dans le chemin d’accès système sur l’ordinateur client.

  • Le type de l’entrée de Registre du chemin d’accès est incorrect sur l’ordinateur client SMS.

Le problème peut également se produire lorsque le service Windows Management Instrumentation (WMI) ne démarre pas en temps voulu.

Résolution

Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Méthode 1 : Assurez-vous que la variable %SystemRoot%\System32\Wbem figure dans le chemin d’accès système sur l’ordinateur client

  1. Cliquez sur Démarrer, sur exécuter, tapez sysdm.cpl, puis cliquez sur OK.

  2. Cliquez sur l’onglet Avancé , puis cliquez sur Variables d’environnement.

  3. Sous variables système, cliquez sur le tracé, puis cliquez sur Modifier.

  4. Assurez-vous que ce %SystemRoot%\System32\Wbem est répertorié dans la zone valeur de la Variable . Si cette valeur n’est pas répertoriée, vous devez l’ajouter. Pour ce faire, procédez comme suit :

    1. Dans la boîte de dialogue Modifier la Variable système , cliquez sur après la fin du texte dans la zone valeur de la Variable et puis tapez ce qui suit :

      ;%SystemRoot%\System32\Wbem

    2. Cliquez trois fois sur OK pour enregistrer les modifications.

Méthode 2 : La valeur du type de l’entrée de chemin d’accès de registre REG_EXPAND_SZ

Avertissement Des problèmes graves peuvent survenir si vous modifiez le Registre incorrectement à l’aide de l’Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent nécessiter que vous réinstalliez votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Modifiez le Registre à vos risques et périls.

  1. Cliquez sur Démarrer, sur exécuter, tapez regedit, puis cliquez sur OK.

  2. Dans l’Éditeur du Registre, recherchez et puis cliquez sur la sous-clé de Registre suivante :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

  3. Assurez-vous que le type de l’entrée de chemin d’accès est REG_EXPAND_SZ et pas REG_SZ. Si le type de cette entrée est REG_SZ, vous devez copier les informations de chemin d’accès, supprimez l’entrée de chemin d’accès existante et puis créer une nouvelle entrée de type REG_EXPAND_SZ. Pour ce faire, procédez comme suit :

    1. Dans l’Éditeur du Registre, double-cliquez sur la valeur de chemin d’accès .

    2. Cliquez sur le texte dans la zone données de la valeur et cliquez sur Copier, puis cliquez sur Annuler.

    3. Collez le texte dans un document du bloc-notes.

    4. Dans l’Éditeur du Registre, cliquez droit sur le chemin d’accès, puis cliquez sur Supprimer.

    5. Dans la barre de menus, cliquez sur Modifier, pointez sur Nouveau, puis cliquez sur Valeur de chaîne extensible.

    6. Tapez le chemin d’accèset appuyez sur ENTRÉE.

    7. Double-cliquez sur le chemin d’accès.

    8. Avec le bouton droit de la zone données de la valeur et cliquez sur Coller, puis cliquez sur OK.

    9. Quittez l'Éditeur du Registre.

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

l’ID d’événement 10003 est connecté et que vous ne pouvez pas utiliser l’Installation poussée du Client pour installer un Client avancé de SMS 2003

Références

Pour plus d’informations sur le dépannage des Installations de Push de Client avancé, consultez l’article suivant dans la Base de connaissances Microsoft :

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