Les performances sont médiocres lors de l’utilisation du profil utilisateur par défaut personnalisé dans Windows

Symptôme

Prenons l’exemple du scénario suivant :

  • Vous créez un nouveau profil d'utilisateur par défaut et l'activez.

  • Un nouvel utilisateur se connecte en utilisant un profil créé à partir du profil par défaut sur un ordinateur Windows 10, Windows Server 2016 ou Windows Server 2019.

Dans ce scénario, il se peut que vous rencontriez l'un ou plusieurs des problèmes d'installation suivants :

  • Les icônes du bureau peuvent mettre longtemps à s'afficher.

  • Les performances sont médiocres lorsque vous démarrez ou naviguez dans Internet Explorer ou Microsoft Edge.

  • Les erreurs ESENT comme celles qui suivent sont enregistrées dans le journal des événements :

    EventLogID : 454

    TaskHostW : PID

    WebCacheLocal : « La récupération/restauration de la base de données a échoué en raison d'une erreur inattendue -1907. »

    Remarque Le message du journal complet de l'événement peut également indiquer une association avec un emplacement de dossier utilisateur différent, tel que « C:\Utilisateurs\Administrateur ».

Cause

Ce problème se produit parce que le profil utilisateur par défaut comprend une copie verrouillée de la base de données cache d’un autre utilisateur.

Lorsqu’un nouvel utilisateur se connecte à l’ordinateur, le contenu du profil utilisateur par défaut est intégré à son nouveau profil. Comme l'environnement et le bureau Windows commencent à charger, la base de données ne peut pas être entièrement initialisée pour l'utilisation. Les applications qui utilisent la base de données connaissent des performances négatives ou signalent des erreurs.

Résolution

Pour résoudre ce problème, procédez comme suit :

Étape 1

Connectez-vous à chaque ordinateur affecté en utilisant un compte qui a des informations d'identification administratives, puis supprimez le fichier et le dossier cachés suivants s'ils existent :

File: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
Folder: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache


Étape 2

Pour chaque compte utilisateur sur l'ordinateur, assurez-vous que l'utilisateur est déconnecté complètement et que le profil est complètement déchargé, puis supprimez le fichier et le dossier cachés suivants s'ils existent :

File: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCacheLock.dat
Folder: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCache

Remarque <affectedUserFolder> est un espace réservé au nom du dossier de profil de l'utilisateur. Par exemple, pour le compte utilisateur de l'administrateur, le dossier est sous C:\Utilisateurs\Administrateur. Vous devez supprimer les fichiers et dossiers ci-dessus pour chaque compte utilisateur affecté sur l'ordinateur.

Comment afficher les fichiers cachés

Pour afficher les fichiers masqués, procédez comme suit :

  1. Dans Internet Explorer, sélectionnez Fichier, puis sélectionnez Ouvrir.

  2. Dans l’onglet Affichage, sélectionnez l'option Afficher les fichiers, dossiers et lecteurs cachés.

  3. Désélectionnez l'option Masquer les fichiers du système d'exploitation protégés (Recommandé), puis cliquez sur OK.

Remarque Nous vous recommandons de re-sélectionner les deux options une fois le problème résolu.

Informations supplémentaires

Étant donné que la base de données de cache est conçue pour être générée par utilisateur au moment de la connexion initiale sur un ordinateur individuel, Microsoft ne recommande pas ou ne prend pas en charge l'inclusion de la base de données de cache dans le profil utilisateur par défaut ou tout autre profil qui est destiné à être utilisé comme un modèle.

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