Les envois de fonds de zéro dollar sont versés à la récupération par lots lors du traitement des paiements EFT dans la gestion des fournisseurs

Cet article fournit une résolution du problème selon lequel les envois de fonds de zéro dollar ne seront pas affichés et ne seront pas envoyés à la récupération par lots lors du traitement des paiements EFT dans La gestion des fournisseurs pour Microsoft Dynamics GP.

S’applique à : Microsoft Dynamics GP
Numéro de la base de connaissances d’origine : 2506000

Symptômes

Lorsque vous publiez un ordinateur case activée lot pour les transferts de fonds électroniques (EFT) dans La gestion des fournisseurs dans Microsoft Dynamics GP, les EFT valides sont affichés. Toutefois, les envois de fonds de zéro dollar ne seront pas post et aller à la récupération par lots.

Cause

Ce comportement peut se produire si les conditions suivantes sont remplies :

  • Vous utilisez vos propres numéros de case activée EFT dans la configuration du checkbook
  • La valeur dans le champ Numéro de paiement EFT suivant contient le préfixe REMIT
  • Le chéquier est marqué comme Ne pas autoriser les vérifications dupliquées

Un problème de publication peut se produire si le nouveau numéro REMIT a déjà été utilisé dans le passé. Le numéro suivant pour le TEF est stocké dans la table Checkbook Electronic Funds Master (CM00101). Toutefois, le processus d’attribution de nombres case activée à des envois de fonds de zéro dollar est dirigé vers les tables clés PM (PM00400) et obtient le numéro DE REMISE maximal utilisé pour la dernière fois. Les deux peuvent se chevaucher et provoquer un doublon, ce qui entraînerait l’accès à la récupération par lots, car les vérifications en double ne sont pas autorisées dans ce chéquier.

Résolution

Si le lot est en récupération par lots, suivez les étapes ci-dessous pour résoudre le problème. Toutefois, si vous avez déjà publié le lot, passez à l’étape 3 pour empêcher les transferts de fonds de zéro dollar d’accéder à Batch Recovery dans les exécutions ultérieures.

  1. Traitez le lot dans Récupération par lots. Pour ce faire, dans le menu Microsoft Dynamics GP, pointez sur Outils, sur Routines, puis sélectionnez Récupération par lots. Sélectionnez le lot, puis sélectionnez Continuer.

    Remarque

    Si le lot ne quitte pas batch Recovery, suivez les étapes décrites dans l’article suivant pour rétablir le lot sur Disponible status à l’aide de SQL Server Management Studio.
    Un lot est conservé dans les status Publication, Réception, Occupé, Marqué, Verrouillé ou Modifié dans Microsoft Dynamics GP

  2. Dans la fenêtre Entrée par lot fournisseurs, sélectionnez le lot et sélectionnez Publier.

    Remarque

    Si les envois de fonds de zéro dollar sont les seules transactions du lot case activée, ils doivent publier la deuxième fois, car ils peuvent s’incrémenter correctement à partir du dernier numéro REMIT utilisé dans la table Clés PM.

  3. Modifiez le numéro de paiement EFT suivant dans le chéquier pour commencer par un autre préfixe. Pour cela, procédez comme suit :

    1. Sélectionnez Cartes, pointez sur Finances, puis sélectionnez Chéquier.
    2. Sélectionnez l’ID du checkbook.
    3. Sélectionnez le bouton EFT Bank , puis fournisseursOptions.
    4. Dans la section Numéros de paiement EFT, remplacez le préfixe REMIT par un préfixe différent tel que EFT dans le champ Numéro de paiement EFT SUIVANT .
    5. Sélectionnez OK pour fermer la fenêtre. Sélectionnez à nouveau OK , puis Enregistrer.