Les utilisateurs sont invités de manière inattendue à taper un mot de passe par une base de données authentifiées Windows dans Microsoft Dynamics SL 2011

Symptômes

Les utilisateurs doivent fournir un mot de passe lorsqu’ils ouvrent une session une base de données dans Microsoft Dynamics SL 2011 authentifiée Windows une fois que le système est mis à niveau à partir d’une version précédente de Microsoft Dynamics SL.

Cause

Ce problème se produit car une nouvelle fonctionnalité a été ajoutée dans Microsoft Dynamics SL 2011 à la possibilité d’exiger la saisie d’un mot de passe lors de la session utilisateur, même lorsque l’authentification Windows est utilisée. Lors de la mise à niveau d’une base de données qui utilisaient l’authentification SQL, mot de passe de chaque utilisateur est conservé et est obligatoire lorsque l’utilisateur ouvre une session sur Microsoft Dynamics SL 2011.

Résolution

Si vous ne souhaitez pas exiger la saisie d’un mot de passe pour une base de données authentifiées Windows, supprimez la valeur de la zone de mot de passe sur l’écran de Maintenance de l’utilisateur (95.260.00) pour tous les utilisateurs, à l’exception de l’utilisateur. Pour ce faire, utilisez une des méthodes suivantes.

Méthode 1:

1. Connectez-vous à Microsoft Dynamics SL en tant que l’utilisateur SYSADMIN.

2. sous le groupe module d’Administration , ouvrez l’écran (95.260.00) de Maintenance utilisateur .

3. Sélectionnez l’ID utilisateur dans la zone ID de l’utilisateur .

4. Supprimez de la valeur dans la zone mot de passe .

5. Enregistrez et répétez pour chaque utilisateur.


Method 2:

Remarque Avant de suivre les instructions fournies dans cette section, assurez-vous que vous disposez d’une copie de sauvegarde complète de la base de données que vous pouvez restaurer si un problème survient.

  1. Déconnecter tous les utilisateurs de la base de données Microsoft Dynamics SL.

  2. Exécutez l’instruction SQL suivante dans Microsoft SQL Server Management Studio sur votre base de données système de Microsoft Dynamics SL 2011 pour supprimer les mots de passe pour tous les utilisateurs, à l’exception de Sysadmin :

    update userrec set Password = '' where UserId not like ('SYSADMIN')

Plus d'informations

Pour plus d’informations, consultez la rubrique « Connexion Microsoft Dynamics SL » dans la section référence du Guide de l’aide de Microsoft Dynamics SL 2011 ou de l’utilisateur.

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