Des affichages d’activité en double peuvent apparaître lors de l’affichage d’une liste d’affichages d’activité dans Microsoft Dynamics CRM 2011

Cet article fournit une solution à un problème où des affichages d’activité en double peuvent apparaître lorsque vous affichez une liste d’affichages d’activité dans Microsoft Dynamics CRM 2011.

S’applique à : Microsoft Dynamics CRM 2011
Numéro de la base de connaissances d’origine : 2637480

Symptômes

Lors de l’affichage d’une liste d’affichages d’activité dans Microsoft Dynamics CRM 2011, les affichages peuvent s’afficher comme ayant un doublon. Lorsque vous accédez à Paramètres, sélectionnez Personnalisations et Personnaliser le système, la solution par défaut s’affiche. Ensuite, sélectionnez Entités, choisissez l’entité dans laquelle la vue dupliquée est affichée, puis sélectionnez Affichages. La liste complète des affichages pour le système s’affiche. Les vues dupliquées ont une balise de description (à utiliser de façon asynchrone).

Cause

À un moment donné, la valeur de type de requête a été modifiée pour les vues. Qui aurait pu se trouver dans le système actuel ou avoir été mis à jour lors d’une importation de personnalisations à partir d’un environnement distinct. La valeur querytype dans le fichier customization.xml s’affiche sous la forme 0 au lieu de 1024.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Accédez à Paramètres , puis sélectionnez Solutions dans la section Personnalisation .
  2. Sélectionnez Nouveau pour une nouvelle solution et fournissez des valeurs pour tous les champs obligatoires. Ensuite, enregistrez la solution.
  3. Sélectionnez Ajouter existant, puis ajoutez l’entité ou les entités qui affichent les symptômes.
  4. Enregistrez la solution, puis sélectionnez Exporter la solution et enregistrez le fichier.
  5. Extrayez le contenu du fichier zip créé et ouvrez le fichier customizations.xml.
  6. Recherchez ensuite les vues dupliquées. Ce qui peut être fait facilement en recherchant à utiliser de manière asynchrone.
  7. Ensuite, modifiez la valeur de type de requête pour lire 1024 au lieu de 0.
  8. Répétez les étapes 6 et 7 pour toutes les vues qui s’affichent en tant que doublons.
  9. Enregistrez le fichier customizations.xml.
  10. Compressez à nouveau les fichiers extraits et réimportez-les dans Microsoft Dynamics CRM.
  11. Publiez les modifications apportées à toutes les entités affectées.

Informations supplémentaires

Le système est conçu pour ignorer les vues avec un type de requête 1024 dans l’interface utilisateur.