Échec de GetReportOptions dans report Scheduler dans Microsoft Business Solutions - Business Portal avec Microsoft Dynamics SL

Cet article fournit une solution à une erreur qui se produit lorsque vous entrez report Scheduler dans Microsoft Business Solutions - Business Portal avec Microsoft Dynamics SL.

S’applique à : Microsoft Dynamics SL
Numéro de la base de connaissances d’origine : 912091

Symptômes

Lorsque vous entrez Report Scheduler dans Microsoft Business Solutions - Business Portal avec Microsoft Dynamics SL, vous pouvez recevoir le message d’erreur suivant :

Échec de GetReportOptions. Erreur info= <soap :Server : System.Web.Services.Protocols.SoapExcpetion : le serveur n’a pas pu traiter la demande. >--- System.NullReferenceExcpetion : la référence d’objet n’est pas définie sur une instance d’un objet.

Cause

Le client Microsoft Solomon n’est pas installé sur le serveur qui exécute Business Portal.

Résolution

Pour installer le client Microsoft Solomon sur le serveur qui exécute Business Portal, procédez comme suit :

  1. Mapper un lecteur au serveur qui exécute Microsoft Solomon :

    1. Dans Windows Explorer, sélectionnez Mapper le lecteur réseau dans le menu Outils.

    2. Dans la liste Lecteur , sélectionnez une lettre de lecteur.

    3. Dans la zone Dossier , tapez le chemin du dossier Solomon sur le serveur qui exécute Microsoft Solomon.

      Remarque

      Par défaut, le dossier Solomon se trouve à l’emplacement \\SolomonServerName\ProgramFiles\Solomon. Dans cet exemple, SolomonServerName signifie nom du serveur qui exécute Microsoft Solomon.

  2. Dans le dossier Solomon, ouvrez le dossier Wrkstn.

  3. Exécutez le fichier Setup.exe qui se trouve dans le dossier Wrkstn.