Message d’erreur lors de la création de rapports dans Microsoft Dynamics NAV 2009 : « le fichier RDLC n’est pas un document XML bien formé »

Modèle : CPR - NAV - correctif

N° de bogue : 108436 (Maintenance du contenu)bogue #: 47314 (Vedbaek SE)

PUBLICATION RAPIDE ARTICLES FOURNISSENT DES INFORMATIONS DIRECTEMENT À PARTIR DE L’ORGANISATION DE SUPPORT TECHNIQUE DE MICROSOFT. LES INFORMATIONS PRÉSENTÉES ICI SONT CRÉÉES EN RÉPONSE À ÉMERGENTS OU UNIQUES RUBRIQUES, OU EST DESTINÉ À COMPLÉTER LES AUTRES INFORMATIONS DE LA BASE DE CONNAISSANCES.

Symptômes

Envisagez le scénario suivant dans Microsoft Dynamics NAV 2009. Vous modifiez la disposition d’un rapport dans le Concepteur de rapports. Ensuite, vous chargez la mise en page de rapport. Dans ce cas de figure, le message d’erreur suivant s’affiche :

Le fichier RDLC n’est pas un document XML bien formé.


En outre, la mise en page modifiée n’est pas chargé.

Cause

Ce problème se produit lorsque le chemin d’accès du dossier temporaire contient des caractères régionaux, tels que ß, á, æ, å ou ø. Le chemin d’accès du dossier temporaire peut être généré en fonction de l’ID utilisateur. Par conséquent, ce problème se produit également lorsque l’ID d’utilisateur contient des caractères régionaux.

Solution de contournement

Pour contourner ce problème, modifiez les TEMP et TMP variables paramètres d’environnement pour pointer vers les dossiers qui n’ont aucuns caractères régionaux.

Résolution

Un correctif pris en charge est désormais disponible auprès de Microsoft. Le correctif résout le problème qui est décrit dans cet article. Appliquez le correctif uniquement aux systèmes rencontrant ce problème spécifique.

Pour résoudre ce problème immédiatement, contactez votre partenaire Microsoft Dynamics ou le Support technique pour Microsoft Dynamics et les produits connexes obtenir le correctif. Si vous avez accès à l’assistance en ligne, que vous pouvez vous connecter à Microsoft Dynamics site et créer une demande de support. Pour ce faire, visitez le site Web de Microsoft à l'adresse suivante :

https://mbs.microsoft.com/support/newstart.aspxVous pouvez également contacter le Support technique pour Microsoft Dynamics et les produits associés par téléphone. Pour ce faire, visitez le site Web de Microsoft à l'adresse suivante :

Partenaires

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+ContactsClients

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmDans certains cas, les frais généralement encourus pour la prise en charge des appels peuvent être annulés si un technicien du Support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question.

Si ce correctif n’est pas publié pour le téléchargement public (autrement dit, qu'une URL publique pour ce correctif n’est pas fournie dans cet article), distribution nécessite l’approbation du responsable, membre de l’équipe escalade ou responsable technique et les informations suivantes s’appliquent :

  • Pour recevoir le correctif, les clients doivent être confrontés au bogue qui est mentionné dans la section « Symptômes ».

  • Vous devez suivre les clients que vous envoyez ce correctif et fournissez le prochain service pack dès qu’il sera disponible (si un service pack est commercialisé).

Ce correctif doit être inclus dans le Service Pack 1 pour Microsoft Dynamics NAV 2009.



Comment faire pour obtenir le correctif logiciel de Microsoft Dynamics NAV ou mettre à jour des fichiers

Une fois que vous demandez un correctif de Microsoft Dynamics NAV ou un fichier de mise à jour à partir d’un Support technique pour Microsoft Dynamics, un lien hypertexte sera envoyé dans un message électronique pour vous.


Le message électronique contiendra un lien hypertexte et un mot de passe. Vous pouvez utiliser le lien hypertexte pour télécharger le correctif logiciel de Microsoft Dynamics NAV ou les fichiers de mise à jour. Lorsque vous cliquez sur le lien hypertexte, la boîte de dialogue Téléchargement de fichier – Avertissement de sécurité s’ouvre. Puis, vous êtes invité à exécuter, à enregistrer ou à annuler le téléchargement.


Si vous cliquez sur exécuter, les fichiers de démarrer le téléchargement et le processus d’extraction. Vous devez spécifier un dossier pour les nouveaux fichiers et ensuite fournir le mot de passe.


Si vous cliquez sur Enregistrer, vous devez spécifier un chemin d’accès pour enregistrer le fichier compressé. Lorsque vous ouvrez le fichier que vous avez enregistré, vous êtes invité à spécifier un chemin d’accès pour les fichiers. Vous devez ensuite fournir le mot de passe fourni dans le message électronique.


Si vous cliquez sur Annuler, le processus de téléchargement s’arrête.



Comment installer un correctif Microsoft Dynamics NAV ou un fichier de mise à jour

Les mises à jour et correctifs logiciels de plate-forme Microsoft Dynamics NAV sont accessibles sous forme de fichiers unique. Pour installer un correctif Microsoft Dynamics NAV ou une mise à jour, vous devez remplacer les fichiers d’installation de Microsoft Dynamics NAV existantes avec le correctif ou les mise à jour fichiers. Pour ce faire, procédez comme suit.

Étape 1 : Remplacer le fichier d’installation du client Microsoft Dynamics NAV

Dans l’installation du client Microsoft Dynamics NAV, remplacez les fichiers suivants en utilisant le fichier de correctif ou la mise à jour.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Dbm.dll

6.0.28463.0

444,216

25-Jan-2009

16:37

x86

Fin.exe

6.0.28463.0

12,240,712

25-Jan-2009

16:38

x86

Finhlink.exe

6.0.28463.0

452,424

25-Jan-2009

16:38

x86

Finsql.exe

6.0.28463.0

12,326,720

25-Jan-2009

16:38

x86

Nc_netb.dll

6.0.28463.0

108,352

25-Jan-2009

16:38

x86

Nc_tcp.dll

6.0.28463.0

108,352

25-Jan-2009

16:38

x86

Nc_tcps.dll

6.0.28463.0

153,424

25-Jan-2009

16:38

x86

Ndbcs.dll

6.0.28463.0

1,337,152

25-Jan-2009

16:37

x86

Slave.exe

6.0.28463.0

161,600

25-Jan-2009

16:38

x86


Remarque Le client Microsoft Dynamics NAV est habituellement installé dans le répertoire suivant.


C:\Program Files\Microsoft Dynamics NAV\60\Classic
Pour remplacer les fichiers existants de Microsoft Dynamics NAV, procédez comme suit :

  1. Fermez Microsoft Dynamics NAV.

  2. Recherchez le répertoire d’installation de client Microsoft Dynamics NAV.

  3. Copiez les fichiers que vous avez téléchargé.

  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de client Microsoft Dynamics NAV.

  5. Dans la boîte de dialogue Confirmer le remplacement du fichier , cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.

Étape 2 : Remplacer le fichier d’installation de serveur de base de données Microsoft Dynamics NAV

Si vous exécutez l’option Native, dans l’installation du serveur de base de données Microsoft Dynamics NAV, remplacez les fichiers suivants à l’aide du correctif logiciel ou le fichier de mise à jour.

Remarque : Si vous exécutez l’option SQL, ignorez cette étape.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Dbm.dll

6.0.28463.0

444,216

25-Jan-2009

16:37

x86

Nc_netb.dll

6.0.28463.0

108,352

25-Jan-2009

16:38

x86

Nc_tcp.dll

6.0.28463.0

108,352

25-Jan-2009

16:38

x86

Nc_tcps.dll

6.0.28463.0

153,424

25-Jan-2009

16:38

x86

Slave.exe

6.0.28463.0

161,600

25-Jan-2009

16:38

x86


Pour remplacer ces fichiers, procédez comme suit :

  1. Localisez le répertoire d’installation de serveur de base de données Microsoft Dynamics NAV.



    Remarque En règle générale, le serveur de base de données Microsoft Dynamics NAV est installé dans le répertoire suivant :

    C:\Program Files\Microsoft Dynamics NAV\60\Database Server\

  2. Arrêter le serveur de base de données Microsoft Dynamics NAV, si elle est en cours d’exécution.

  3. Copiez les fichiers que vous avez téléchargé.

  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de Microsoft Dynamics NAV server.

  5. Lorsque vous y êtes invité, cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.

  6. Démarrez le serveur de base de données Microsoft Dynamics NAV.

Étape 3 : Remplacer le fichier d’installation de Microsoft Dynamics NAV Application Server.

Dans l’installation de Microsoft Dynamics NAV Application Server, remplacez les fichiers suivants.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Dbm.dll

6.0.28463.0

444,216

25-Jan-2009

16:37

x86

Nas.exe

6.0.28463.0

2,070,328

25-Jan-2009

16:38

x86

Nassql.exe

6.0.28463.0

2,152,272

25-Jan-2009

16:38

x86

Nc_netb.dll

6.0.28463.0

108,352

25-Jan-2009

16:38

x86

Nc_tcp.dll

6.0.28463.0

108,352

25-Jan-2009

16:38

x86

Nc_tcps.dll

6.0.28463.0

153,424

25-Jan-2009

16:38

x86

Ndbcs.dll

6.0.28463.0

1,337,152

25-Jan-2009

16:37

x86

Slave.exe

6.0.28463.0

161,600

25-Jan-2009

16:38

x86

Pour remplacer les fichiers, procédez comme suit.

  1. Arrêtez le serveur d’Application Microsoft Dynamics NAV.

  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Application Server.


    Remarque En général, Microsoft Dynamics NAV Application Server est installé dans le répertoire suivant :

    C:\Program Files\Microsoft Dynamics NAV\60\Application Server\

  3. Copiez les fichiers que vous avez téléchargé.

  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de Microsoft Dynamics NAV Application Server.

  5. Cliquez sur Oui pour remplacer les fichiers dans le répertoire.

  6. Démarrez le serveur d’Application Microsoft Dynamics NAV.

Étape 4 : Remplacer le fichier d’installation de pilote ODBC de Microsoft Dynamics NAV

Si vous avez le pilote ODBC de Microsoft Dynamics NAV, remplacez les fichiers suivants dans l’installation du pilote ODBC de Microsoft Dynamics NAV.

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Dbm.dll

6.0.28463.0

444,216

25-Jan-2009

16:37

x86

Nc_netb.dll

6.0.28463.0

108,352

25-Jan-2009

16:38

x86

Nc_tcp.dll

6.0.28463.0

108,352

25-Jan-2009

16:38

x86

Nc_tcps.dll

6.0.28463.0

153,424

25-Jan-2009

16:38

x86

Slave.exe

6.0.28463.0

161,600

25-Jan-2009

16:38

x86

Pour remplacer les fichiers, procédez comme suit.

  1. Recherchez le répertoire d’installation du pilote ODBC de Microsoft Dynamics NAV.


    Remarque En général, le pilote ODBC de Microsoft Dynamics NAV est installé dans le répertoire suivant :

    C:\Program Files\Microsoft Dynamics NAV\60\ODBC

  2. Copiez les fichiers que vous avez téléchargé.

  3. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de pilote ODBC de Microsoft Dynamics NAV.

  4. Cliquez sur Oui pour remplacer les fichiers dans le répertoire.

État

Microsoft a confirmé qu'il s'agissait d'un bogue dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft

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Auteur : lohndorf
Writer : v-jozhen
Réviseur technique : lohndorf
Éditeur :

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